Almost all games crash

Good evening everyone,

Ever since I installed my new AMD Radeon RX 6700 and formatted my computer a few days later due to a mess I made, I can’t get any game to work on Steam anymore especially the ones that require 3D acceleration, I tried to follow the guide that is in the forum and in fact I installed the drivers but it still skips everything, would you kindly give me a hand?

Thank you all

What do you mean by it “skips everything”?

Also, from a terminal, please run the below command and post the content in this thread.

inxi -FGAxxz

I mean the various games have a start after which, when you have to move the character rather than have to shoot or other such things they all crash

[ej@ejs ~]$ inxi -FGAxxz
System:
  Kernel: 6.8.9-arch1-2 arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
  Desktop: KDE Plasma v: 6.0.4 tk: Qt v: N/A wm: kwin_x11 dm: SDDM
    Distro: EndeavourOS base: Arch Linux
Machine:
  Type: Desktop System: Gigabyte product: X470 AORUS GAMING 7 WIFI v: N/A
    serial: <superuser required>
  Mobo: Gigabyte model: X470 AORUS GAMING 7 WIFI-CF v: x.x
    serial: <superuser required> UEFI: American Megatrends v: F3
    date: 03/14/2018
CPU:
  Info: 6-core model: AMD Ryzen 5 2600 bits: 64 type: MT MCP arch: Zen+ rev: 2
    cache: L1: 576 KiB L2: 3 MiB L3: 16 MiB
  Speed (MHz): avg: 1519 high: 1550 min/max: 1550/3400 boost: enabled cores:
    1: 1550 2: 1442 3: 1472 4: 1550 5: 1550 6: 1550 7: 1520 8: 1550 9: 1550
    10: 1426 11: 1528 12: 1550 bogomips: 81617
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Graphics:
  Device-1: AMD Navi 22 [Radeon RX 6700/6700 XT/6750 XT / 6800M/6850M XT]
    vendor: Gigabyte driver: amdgpu v: kernel arch: RDNA-2 pcie: speed: 16 GT/s
    lanes: 16 ports: active: HDMI-A-2 empty: DP-1, DP-2, HDMI-A-1, Writeback-1
    bus-ID: 0b:00.0 chip-ID: 1002:73df
  Device-2: Generic Integrated RGB Camera driver: uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 bus-ID: 5-3.4:7 chip-ID: 2ef4:4944
  Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 23.2.7
    compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting,radeon
    alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 2560x1080 s-dpi: 96
  Monitor-1: HDMI-A-2 mapped: HDMI-A-1 model: LG (GoldStar) HDR WFHD
    res: 2560x1080 dpi: 81 diag: 869mm (34.2")
  API: EGL v: 1.5 platforms: device: 0 drv: radeonsi device: 1 drv: swrast
    surfaceless: drv: radeonsi x11: drv: radeonsi inactive: gbm,wayland
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 24.0.7-arch1.3
    glx-v: 1.4 direct-render: yes renderer: AMD Radeon RX 6700 XT (radeonsi
    navi22 LLVM 17.0.6 DRM 3.57 6.8.9-arch1-2) device-ID: 1002:73df
  API: Vulkan v: 1.3.279 surfaces: xcb,xlib device: 0 type: discrete-gpu
    driver: amd device-ID: 1002:73df
Audio:
  Device-1: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel pcie:
    speed: 16 GT/s lanes: 16 bus-ID: 0b:00.1 chip-ID: 1002:ab28
  Device-2: AMD Family 17h HD Audio vendor: Gigabyte driver: snd_hda_intel
    v: kernel pcie: speed: 8 GT/s lanes: 16 bus-ID: 0d:00.3 chip-ID: 1022:1457
  Device-3: Logitech Z-5 Speakers driver: hid-generic,snd-usb-audio,usbhid
    type: USB rev: 1.1 speed: 12 Mb/s lanes: 1 bus-ID: 1-3:3 chip-ID: 046d:0a13
  Device-4: C-Media TONOR TC-777 Audio Device
    driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 1.1 speed: 12 Mb/s
    lanes: 1 bus-ID: 1-4:4 chip-ID: 0d8c:0134
  Device-5: Realtek USB2.0 Audio driver: hid-generic,snd-usb-audio,usbhid
    type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 bus-ID: 5-3.1:6
    chip-ID: 0bda:4a10
  API: ALSA v: k6.8.9-arch1-2 status: kernel-api
  Server-1: PipeWire v: 1.0.6 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin
Network:
  Device-1: Intel I211 Gigabit Network vendor: Gigabyte driver: igb v: kernel
    pcie: speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 05:00.0 chip-ID: 8086:1539
  IF: enp5s0 state: down mac: <filter>
  Device-2: Intel Wi-Fi 5 Wireless-AC 9x6x [Thunder Peak] driver: iwlwifi
    v: kernel pcie: speed: 5 GT/s lanes: 1 bus-ID: 06:00.0 chip-ID: 8086:2526
  IF: wlan0 state: up mac: <filter>
Bluetooth:
  Device-1: Intel Wireless-AC 9260 Bluetooth Adapter driver: btusb v: 0.8
    type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 bus-ID: 1-2:2 chip-ID: 8087:0025
  Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.1
    lmp-v: 10
Drives:
  Local Storage: total: 1.36 TiB used: 318.64 GiB (22.8%)
  ID-1: /dev/sda vendor: Samsung model: SSD 870 QVO 1TB size: 931.51 GiB
    speed: 6.0 Gb/s serial: <filter>
  ID-2: /dev/sdb vendor: Samsung model: SSD 860 EVO 500GB size: 465.76 GiB
    speed: 6.0 Gb/s serial: <filter>
Partition:
  ID-1: / size: 914.85 GiB used: 318.64 GiB (34.8%) fs: ext4 dev: /dev/sda2
  ID-2: /boot/efi size: 998 MiB used: 296 KiB (0.0%) fs: vfat dev: /dev/sda1
Swap:
  Alert: No swap data was found.
Sensors:
  System Temperatures: cpu: 36.9 C mobo: N/A gpu: amdgpu temp: 45.0 C
    mem: 48.0 C
  Fan Speeds (rpm): N/A gpu: amdgpu fan: 0
Info:
  Memory: total: 48 GiB available: 46.99 GiB used: 6.15 GiB (13.1%)
  Processes: 350 Power: uptime: 33m wakeups: 0 Init: systemd v: 255
    default: graphical
  Packages: pm: pacman pkgs: 1246 Compilers: clang: 17.0.6 gcc: 14.1.1
    Shell: Bash v: 5.2.26 running-in: yakuake inxi: 3.3.34
[ej@ejs ~]$ 

Can you list some of the games please? Also run and post the below command.

pacman -Qqs "steam|vulk|vlk"

SWTOR, CAPTAIN OF INDUSTRIES, BG3…

[ej@ejs ~]$ pacman -Qqs "steam|vulk|vlk"
amdvlk
lib32-amdvlk
lib32-vulkan-icd-loader
lib32-vulkan-radeon
qt6-shadertools
spirv-tools
steam
vkd3d-proton-git
vulkan-headers
vulkan-icd-loader
vulkan-radeon
vulkan-tools
[ej@ejs ~]$ 

Hmm. Have you already tried modifying launch options?

Captain of Industry - https://www.protondb.com/app/1594320
STAR WARS: The Old Republic - https://www.protondb.com/app/1286830

1 Like

Try removing amdvlk and tesitng with only vulkan-radeon.

"Installation

Install the mesa package, which provides the DRI driver for 3D acceleration.

Support for accelerated video decoding is provided by libva-mesa-driver and lib32-libva-mesa-driver for VA-API and mesa-vdpau and lib32-mesa-vdpau packages for VDPAU."

Arch Wiki AMDGPU

Undoubtedly we are close because on SWTOR you manage to get as far as the character choice, however, when the latter you choose works up to 80% of the loading is all of a sudden crashes

We were close so I completed by solving by installing xf86-video-vesa

Thank you all for the invaluable help