After Recent Updates any graphic intensive game, crashes after 30~ish minutes

I’m trying to figure out why my BG3 crashes after roughly 30 minutes, where as I can play something less intense like Vampire Survivor w/ no issues w/ no 30 minute cutoff. I’ve tried other graphic intensive games and the issue occur for example “Helldiver’s II”

Issue: Essentially this is a tower connected to a 65" tv, and after 30 minutes the screen goes black and the source is lost, the computer needs a power cycle at this point to regain video function.

I’ve tried rolling back kernels & drivers for vulkan with no luck. As this issue has only recently creeped up, post some yay updates. I’m not seeing any temperature spikes as the system is 4ish months old & clean of dust and not showing any High temp warnings.

I tried the steps in “Almost all games crash” as they seemed the most similar to my issue. Unfortunately I still am running into crash errors

inxi -FGAxxz output:

System:
  Kernel: 6.9.2-arch1-1 arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
  Desktop: KDE Plasma v: 6.0.5 tk: Qt v: N/A wm: kwin_wayland dm: SDDM
    Distro: EndeavourOS base: Arch Linux
Machine:
  Type: Desktop Mobo: Gigabyte model: B760M AORUS ELITE AX v: x.x
    serial: <superuser required> UEFI: American Megatrends LLC. v: F12
    date: 07/24/2023
CPU:
  Info: 14-core (6-mt/8-st) model: 13th Gen Intel Core i5-13600KF bits: 64
    type: MST AMCP arch: Raptor Lake rev: 1 cache: L1: 1.2 MiB L2: 20 MiB
    L3: 24 MiB
  Speed (MHz): avg: 856 high: 1092 min/max: 800/5100:3900 cores: 1: 854
    2: 800 3: 800 4: 800 5: 989 6: 800 7: 1092 8: 1016 9: 1083 10: 800 11: 800
    12: 800 13: 800 14: 800 15: 800 16: 800 17: 800 18: 900 19: 800 20: 800
    bogomips: 139820
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
  Device-1: AMD Navi 32 [Radeon RX 7700 XT / 7800 XT] vendor: Sapphire
    driver: amdgpu v: kernel arch: RDNA-3 pcie: speed: 16 GT/s lanes: 16 ports:
    active: HDMI-A-2 empty: DP-1, DP-2, HDMI-A-1, Writeback-1 bus-ID: 03:00.0
    chip-ID: 1002:747e
  Display: wayland server: X.org v: 1.21.1.13 with: Xwayland v: 24.1.0
    compositor: kwin_wayland driver: X: loaded: amdgpu
    unloaded: modesetting,radeon,vesa alternate: fbdev dri: radeonsi
    gpu: amdgpu display-ID: 0
  Monitor-1: HDMI-A-2 res: 1920x1080 size: N/A
  API: EGL v: 1.5 platforms: device: 0 drv: radeonsi device: 1 drv: swrast
    surfaceless: drv: radeonsi wayland: drv: radeonsi x11: drv: radeonsi
    inactive: gbm
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 24.0.8-arch1.1
    glx-v: 1.4 direct-render: yes renderer: AMD Radeon RX 7800 XT (radeonsi
    navi32 LLVM 17.0.6 DRM 3.57 6.9.2-arch1-1) device-ID: 1002:747e
    display-ID: :1.0
  API: Vulkan v: 1.3.279 surfaces: xcb,xlib,wayland device: 0
    type: discrete-gpu driver: mesa radv device-ID: 1002:747e
Audio:
  Device-1: Intel Raptor Lake High Definition Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:7a50
  Device-2: AMD Navi 31 HDMI/DP Audio driver: snd_hda_intel v: kernel pcie:
    speed: 16 GT/s lanes: 16 bus-ID: 03:00.1 chip-ID: 1002:ab30
  API: ALSA v: k6.9.2-arch1-1 status: kernel-api
  Server-1: PipeWire v: 1.0.7 status: active with: 1: wireplumber
    status: active 2: pipewire-alsa type: plugin 3: pw-jack type: plugin
  Server-2: PulseAudio v: 17.0 status: active
Network:
  Device-1: Intel Raptor Lake-S PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:7a70
  IF: wlan0 state: down mac: <filter>
  Device-2: Realtek RTL8125 2.5GbE vendor: Gigabyte driver: r8169 v: kernel
    pcie: speed: 5 GT/s lanes: 1 port: 3000 bus-ID: 07:00.0 chip-ID: 10ec:8125
  IF: enp7s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth:
  Device-1: Intel AX211 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 bus-ID: 1-14:6 chip-ID: 8087:0033
  Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.3
    lmp-v: 12
Drives:
  Local Storage: total: 2.73 TiB used: 330.25 GiB (11.8%)
  ID-1: /dev/nvme0n1 vendor: Western Digital model: WD BLACK SN850X 1000GB
    size: 931.51 GiB speed: 63.2 Gb/s lanes: 4 serial: <filter> temp: 41.9 C
  ID-2: /dev/nvme1n1 vendor: Western Digital model: WD BLACK SN850X 2000GB
    size: 1.82 TiB speed: 63.2 Gb/s lanes: 4 serial: <filter> temp: 39.9 C
Partition:
  ID-1: / size: 517.04 GiB used: 40.67 GiB (7.9%) fs: ext4 dev: /dev/nvme0n1p3
Swap:
  Alert: No swap data was found.
Sensors:
  System Temperatures: cpu: 34.0 C mobo: 26.0 C gpu: amdgpu temp: 34.0 C
    mem: 40.0 C
  Fan Speeds (rpm): N/A gpu: amdgpu fan: 0
Info:
  Memory: total: 32 GiB available: 31.18 GiB used: 3.97 GiB (12.7%)
  Processes: 368 Power: uptime: 9m wakeups: 0 Init: systemd v: 255
    default: graphical
  Packages: pm: pacman pkgs: 1296 Compilers: gcc: 14.1.1 Shell: Bash
    v: 5.2.26 running-in: konsole inxi: 3.3.34

pacman -Qqs “steam|vulk|vlk” output:

lib32-vulkan-icd-loader
lib32-vulkan-radeon
qt6-shadertools
spirv-tools
steam
vulkan-headers
vulkan-icd-loader
vulkan-radeon
vulkan-tools

Welcome @diddymao :wave: :sunglasses: :enos_flag:

In case it’s a hardware issue, you might consider updating your BIOS, as you are 6 releases behind at the moment. Check the notes, and confirm for yourself if this is worthwhile, as there is a degree of risk in updating your BIOS. If you’ve never updated a BIOS before, I recommend reading these precautions first.
A few of the updates address memory and CPU compatibility, as well as security.

If you are overclocking either CPU / GPU / RAM, return to stock settings until the issue can be resolved.

I’ll give the newest update a try, as it’s around the time issues started occuring.

Update: Flashed BIOS to F17, still lost video in under 30 minutes.

Turns out it was in relation to my TV, I turned off HDR and now games don’t crash.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.