All kernels failing to boot

Hello, the last couple of kernel updates made my kernels stop booting. Happened with 5.18 and 5.18 zen first… I could boot into to 5.15 lts still… Today that kernel was updated and now I can’t boot into it either…this is the error i get.

I booted into live usb. Used chroot to reinstall kernels again but same error persists after reboot. Please help.

1 Like

Is this on a Ryzen system?

No… but amd A10 apu… 7850k from 2014
This is the result when i boot into regular kernel

It may be related to a similar problem I’m having booting in VM. Can you check if it will boot by adding mitigations=off in the grub command line? When you boot and at the grub menu press e for edit and add this in the grub command line. Then press F10 to continue booting. This is temporary to just try to see what happens.

1 Like

Where should I add that?

The end of the line that starts with linux.

If nothing else works, you can chroot and add @jonathon’s kernel repo:

That way you can continue to use an older kernel version for at least some time…

1 Like

That worked! Booted into lts. Thank you thank you… how can I make it permanent?

Okay… so just to be aware this is bypassing the spectre v2 security vulnerabilities but it does answer some questions i had. Maybe @jonathon could explain it better. You can make it permanent but not so sure it’s a good idea.

Edit: It may be a better idea to go the route that @Kresimir recommended.

I installed the 5.10 kernel from Jonathon’s repo. Same result… Stuck at the same error

I’m not sure what to tell you. I’ve had the same issue but only in virtualbox. Maybe @jonathon could advise about that?

1 Like

The screenshots so far don’t show the same error, and don’t show the important part either. Are you able to recover more information from the journal?

What specific steps did you use to install the alternative kernels?

Also, [FAQ] Computer doesn’t boot, boots to a black screen, or stops at a message

1 Like

On file /etc/default/grub add mitigations=off to the lines GRUB_CMDLINE_LINUX and GRUB_CMDLINE_LINUX_DEFAULT and run

sudo grub-mkconfig /boot/grub/grub.cfg

To reverse, remove mitigations=off and rerun the command.

As @ricklinux said in the post above, this is probably a very bad idea.

I really didn’t want to advise to do this. For me it’s just I’m trying to test to figure out why i only have this problem in virtualbox and not vmware or booting on my computer. So it was just to confirm my thoughts.

1 Like

sorry for the late reply, it was 3am for me… :sweat_smile:
I had 5.18, 5.18-zen and 5.15 already installed. the 5.18 ones stopped working after the latest updates, and then lts one the day after.
This is what I currently get if I boot these kernels without mitigations=off

5.15 lts

5.18

5.18 zen

When I get these msgs, keyboard is completely locked up. So I cant switch to text console.
Once I got in by adding mitigations=off, I installed linux-lts510 by
Adding this to my /etc/pacman.conf:

[kernel-lts]
Server = https://repo.m2x.dev/current/$repo/$arch

Import key:

sudo pacman-key --keyserver hkps://keyserver.ubuntu.com --recv-key 76C6E477042BFE985CC220BD9C08A255442FAFF0
sudo pacman-key --lsign 76C6E477042BFE985CC220BD9C08A255442FAFF0

and then

sudo pacman -S linux-lts510

Tried booting that kernel and it failed too.

journal from most recent boot - https://clbin.com/atUkb
journal from second most recent boot - https://clbin.com/4RlNl

From the time stamp, its the journal from when I added the mitigations=off afaik
The failed boots aren’t getting recorded I think.

Strange how it booted the first time you used mitigations=off. Are you trying to enable it permanently and this is happening? Are you sure you have done this correctly?

No the computer only boots if I add mitigations=off… I haven’t added it permanently yet.

Did you install the headers?

Okay sorry i misunderstood. I’m finding it strange that my system boots fine except on virtual box.

Edit:

I missed the word without. :man_facepalming: