After update of the driver r8168 Internet dead on 5.14

After today’s update of the driver r8168 for kernel 5.14 and reboot, the internet was dead on my computer. A reboot to 5.10 LTS (with the r8168 LTS driver) fixed it for now, but I still have the problem with 5.14.

Same here. No internet with update but i don’t have LTS installed.
Now What?
Tell me what to post with regard to system stats and I will…

Same problem here. The problem for me only seems to be limited by the wired internet, it does hang on boot where it says Starting version 249.5-3-arch

Sorry, but if there’s one thing I’ve learned with Arch, it’s to NEVER go without the latest LTS kernel. That helps me at least for now. Do you at least have timeshift or something similar?


r8168 - remove it and reboot. There is an in-built r8169 driver in the kernel that should work.


sudo pacman -R r8168 ?

What will then happen to the r8168-lts, which I need for the LTS kernel?

Hmmm not sure. But it will be in your cache if it needs reinstalling.

Uninstalling r8168 did nothing. It did not automatically take the r8169. But at least nothing happened to the r8168-lts.

worked for me.

Check the files in /etc/modprobe.d/ to make sure r8169 is not blacklisted.

check - the only content in modprobe.d is the blacklisting for watchdog:

# Disable intel mei (including mei_watchdog).
blacklist intel_pmc_bxt
blacklist iTCO_vendor_support

# Do not load the 'iTCO_wdt' watchdog module on boot.
blacklist iTCO_wdt
lsmod | grep -i r816

Does the above return anything?

r8168 208896 0

So it is still picking the r8168 driver.


sudo rmmod r8168

Does the network start working?

Nothing is changing … :hot_face:

:frowning: You may have to remove the r8168-lts package, you can always reinstall from cache. It must be picking it up from there.

What’s the contents of

blacklist r8169

So you still have r8168 installed? Try uninstalling it and reboot:

sudo pacman -R r8168

Yeah I just restored the image from last month from Clonezilla.
What is weird is I had all these updates waiting and so I installed AKM to install the LTS kernel and after reboot the latest kernel works fine… I’ll just keep the LTS installed anyway.