After reboot black screen how to fix

When I reboot endeavoros, to a black screen.
I just installed endeavoros and did not add or remove any programs or set config.
My main problem is in restarting, after restarting, the screen turns black and I have to physically press hold shutdown button the system and restart it.
I am sure that the complete restart process will be done (closed all progress inux), after the restart the screen will be black
I don’t have a problem with the shotdown mode
This problem was even on liveusb, the problem is from archlinux itself. My system is relatively old and there should be no problem in terms of support
How can I fix this?
GPU: intel and amd

Can you be more specific? Else difficult to find help.

Also what EOS iso are you using?


GPU: dual core model Intel core i5-4200M

Installed offline
Sorry, I don’t have internet access on my laptop at the moment. If I have downloaded the version correctly, I will post the complete information


Is the newest iso. That’s ok. Info on system, graphics and boot log will help troubleshooting this hopefully.

Welcome to the EndevourOS forum. I hope you enjoy your time here.

If I remember correctly, a bug popped up in Artemis nova with xfce offline install which is being fixed in Cassini.

Hopefully @joekamprad @dalto or @manuel could shed more light on this.


1 Like

Thank you
The process of closing processes is done correctly, because if it is not finished properly, the system will not be turned off, while the shutdown process is done correctly, the same problem exists in USBlive mode.

The problem is that after closing the processes, the operating system cannot properly restart BIOS.

I even blacklisted iTCO_wdt and blacklisted everything mentioned in the forum, I tried all of them one by one and together, but still the restart is not done properly.
I also did a complete update( sudo pacman -Syu)

It is possible that this is a bug that the BIOS does not restart properly

I just tried the offline install into a virtual machine and it worked OK.
So the problem might be in the GPU drivers.

For starters, the install log will be very useful. You can provide it with command

cat /home/liveuser/endeavour-install.log | eos-sendlog


cat /var/log/endeavour-install.log | eos-sendlog  # on the installed system

and show the returned URL here.

Another useful log is the information about your machine:

inxi -zaG | eos-sendlog

If you can start a TTY (e.g. with keys Ctrl-Alt-F3) on the installed system, that may be the easiest way. But if not, boot the USB installer and give the commands as above.

1 Like

How to send logs (txt)? I can’t send txt file

cat filename.txt | eos-sendlog

No need to convert to PDF.
You can use three backticks (```) before and after the textual output, e.g.

the output goes here

1 Like

Sorry, i removed partitions info from logs

Not convet pdf just rename to pdf

1 Like

Would you show the output of command

pacman -Qs xf86-video


What I would try is:

  • uninstall xf86-video-ati and xf86-video-amdgpu
  • blacklist radeon

and reboot.
If that doesn’t work, I’d uninstall xf86-video-intel too and reboot.
If that doesn’t work, then Intel GPU fails to work.

The next step would be installing xf86-video-amdgpu and reboot.

Please try these and post about all results.

I did everything step by step but unfortunately none of them worked.

Frist picture log restart
All restart logs were like this

We need more info:

  • logs
  • more than “none of them worked”

If you test something, we need

  • the exact commands you did
  • the full output of the commands

EDIT: the picture above is too hard to read for me. Any chance to get the text only version?

For uninstall use command
sudo pacman -R
For add blacklist
sudo nano /etc/modprobe.d/blacklist.conf
blacklist radeon
I checked the output of all the system restart logs and they are all the same as the first picture
I will also put it as text

Reserved this post