After latest update screen goes black when loging in

So is this because of this:

XAUTHORITY is related to the xauth system. The xauth system manages privileges for connecting to the X server, which runs as root. Because the program cannot find the authority file that it thinks you’re specifying in XAUTHORITY, it can’t get permission to connect.


So we have given you number of options to try. You may also want to remove the kernel parameters in the default grub file. I don’t think you need any of them. They are easy to remove or add at any time from the following file using a text editor such as nano.


Once you remove the parameters from the default grub & save you have to update grub with the following command.

sudo grub-mkconfig -o /boot/grub/grub.cfg

Sorry for the late reply. Had to run errands with the kids.
Thanks everyone for the input again! It’s really much appreciated.
I tried all suggestions here, but unfortunately nothing helped yet.

I actually did the update earlier and saw the new kernel coming in. Sorry, I should have mentioned that.
But as just mentioned this didn’t help either.

I ran ‘sudo mkinitcpio -P’ several times today, but it never brought back my desktop (after rebooting and loging in).

I also installed the lts kernel with the listed commands. Again no improvement.

Then I moved the .Xauthority file and restarted lightdm. This fired up the desktop with the login window again. But the behavior was the same: after I typed in my password and hit Enter, the screen went black and a few seconds later my monitor told me it’s not getting a signal and it went into standby again.

Does anyone know what happens exactly desktop-wise after one logs in?

@ricklinux I actually don’t have the modules you listed in my grub file. Here’s the link to it:

I think the mistake I made is to run the inxi command in the live ISO environment, so it’s the modules the live ISO uses I think.
I installed inxi via the terminal on my desktop machine that has the black screen problem and ran it again. You can find the output here:

Sorry for the confusion.

My guess currently is that it’s not a kernel issue, since updating the kernel and even switching to the lts version did not change the behavior. My guess is that the initial update changed some config/setting that causes this behavior. But it’s really just an uneducated guess.

Should I try to reinstall the system via the new live ISO?
I have /home on a separate partition. If I format the / partition and reinstall the system, I guess I have to reinstall all the programs/tools I installed so far. But if I create the same user and do not mark my /home partition for formatting, it should at least keep all my files (including configs in my home directory), correct?

Maybe that would get rid of the issue, since the desktop via the live ISO obviously works.
But I guess it would also be nice to figure out what causes this problem.

I’m just not sure what the issue is. We have gone though most of the things that normally would be done to try to troubleshoot it. When you installed the first time did you install Nvidia drivers after or did you select the non free entry in the grub menu to install.

Edit: If you selected the non free i assume you had no issue when it originally installed.

I selected the non free entry, but I recall that I had to wait for someone to create an ISO that included the driver that supported my graphic card at that point.

That must have been quite some time ago then. The current ISO works like this. If you select the default entry it will install with the nouveau open source drivers. You have to select nonfree entry in order to install the Nvidia drivers.

It was in the beginning (January) of 2020.

The new ISO is a totally new framework. The installation process is way faster.

So are you saying I should reinstall the system?
It keeps my home directory if I create the same user again and do not format the /home partition, correct?
I just wanna make sure that all my configs (ssh, etc.) are still in place after the reinstall.

One thing i just noticed for your board is that there are 10 more updates for your UEFI Bios. You only need to update to the latest. That is something you should do.

Your current UEFI Bios is: UEFI: American Megatrends v: F11 date: 12/06/2019

The latest version is F35b dated 2021/09/06 which might be a beta version. It doesn’t say though. I think you should update your UEFI when you can. Not sure how Gigabytes are set up. On MSI i just download the new Bios file and extract it and save to a usb drive. Then i boot up to the UEFI screen and i can update it from there by browsing for the file on the usb drive.

I think your /home partition would stay intact. I’m not sure about all the configs?

Edit: You can check yourself in your UEFI setup what version and date your UEFI Bios is. I’m just going by the hardware link you posted.

I checked here if i have the right board from your hardware list.

The latest UEFI Bios update is pretty important. There have been numerous updates for AMD AGESA that are for Ryzen. This controls all the power functions for your processor and board. You have a Ryzen 9 3900X. I have a Ryzen 7 3800X with an MSI board and i have also had about 13 UEFI updates. You only need to update to the latest as it has all the previous updates in it.

Edit: Make sure you understand how to update it if you’ve never done it before. You can’t shut it down if it’s not finished flashing. My board automatically reboots in the middle of the process and then flashes and you can see when it’s finished.

OK, I updated to the latest BIOS version.
But now my EndeavourOS Boot Option disappeared.
It still lists the Windows Boot Loader, but it looks like I can’t start linux anymore.
I tried a few things and went through all the options, but I don’t seem to be able to get the EndeavourOS Boot entry back.

in UEFI motherboard
create a profile windows and linux
for Linux

  • check Secure boot off
  • CSM off
  • no legacy
  • all disks to AHCI

check also

sudo efibootmgr -v

or with F12 check boot one One UEFI Pn ( n number disk )

Hi Stephane,
Are you saying I should create two BIOS profiles now and depending on which system I wanna start first go into the BIOS and select the appropriate profile.
This was not necessary before and I would not like to have to go to the BIOS first and select a profile every time I wanna switch the OS.
Or did I misunderstand you?
Edit: where do I run the sudo efibootmgr command?

Those settings might have been reset to defaults in Bios after the update. I think that is why Stephanne asked you to check them.

You could run efibootmgr -v in a tty and post the link. I don’t think sudo is necessary.

I took pictures of my settings before the update and made sure that I set them to the identical values afterwards.
I don’t get to tty anymore, since the BIOS only sees the Windows boot manager.
Or do you guys mean to run it from a live ISO?

Edit: I also just reverted back to my previos BIOS version/profile that I saved. Now it lists EndeavourOS as boot option again.

just a weird question… its a desktop right… all connectors are right ? i moved my pc from upstairs to downstairs… i notice if my hdmi cable not quiet good in the card it show the bios load screen and sysd-boot it booted yesterday 2 times in black. after sysd-boot

checked my hdd seems connected… after put hdmi right in i had back screen…is weird, but that black given was in lts and normal linux.

if a patch in latest kernel fail sure it also give a blackscreen but as bug reports is not so huge…

just wanted to say… already tried with another kernel ?

Yes, it’s a desktop PC and I don’t think any of the connectors are loose. HMDI cable seems to sit tight and sturdy.
Also yes to the other kernels.
I updated the kernel today as well as switched to the lts version.

Reinstalled the latest BIOS version. CMS and secure boot are both off.
But I am again not having an EndeavourOS option under my boot options.

You could run
efibootmgr -v
from the live iso to see if your efi boot entry for EnOS is intact. Please post the output for forum to have look.