After latest update screen goes black when loging in

Hi,

I updated my machine today (last time before was on the weekend) and since the reboot I can’t et into my desktop anymore.
I am still getting my login screen, but after entering my password and hitting Enter the screen goes black and a couple of 2nds later my monitor says ‘No Signal’ and goes into standby.
I already tried #1 and #2 from here, as well as running ‘sudo nvidia-installer-dkms’, via the terminal (CTRL-ALT-F2), but neither of those fixed the issue.
Any tips on how to troubleshoot this issue would be greatly appreciated.

Thanks,
Marcel

Welcome @marcelicious

Have you tried adding the additional enahncements from the wiki page?

Edit: Are you able to use another device to get to the wiki page? If your computer goes to a black screen you can open a TTY and make the changes that are on the wiki.

Edit2: I see on your post you refer to the wiki page. Did you do all of the additional enahancements and regenerate the kernel image before rebooting?

@marcelicious
Maybe you can try adding all of the enhancements on that wiki page including the hook. You can manually create the hook or install the hooks package from the eos repo.

@ricklinux
Thanks for your reply.
I did enhancement 1 and 2.
I didn’t do the screen tearing part, since I didn’t have any issues with it.
I also didn’t create the hook yet. I’ll do that for the future, but I don’t think it’s going to solve my current issue, right.
As far as I understood it, it’s just going to make sure that the kernel images get rebuilt on updates.
Any suggestions on commands I could run or logs I could check to see why the screen goes black after the login? I am it usually goes black for a second or so, but then displays my desktop. This time is apparently stops sending a signal to the monitor and stays black.

I have an Nvidia myself and i don’t usually have any problems with it. I normally have all the enhancements set up. It’s usually nvidia-settings that causes a problem because it doesn’t set it up right when it installs updates. Is this a desktop with Nvidia or Hybrid laptop?

Edit: What you could do is uninstall the nvidia and revert to nouveau open source driver first.

sudo nvidia-installer-dkms -n

Then reboot and see if it’s working. If it is i would reinstall nvidia drivers. Then add all the enhancements. Hopefully that fixes it for you.

1 Like

This didn’t work unfortunately.
I ran ‘sudo nvidia-installer-dkms -n’ and the first time it complained that it can’t switch to the nouveau driver, since steam has a dependency on the lib32-nvidia-utils via lib32-vulkan-driver.
After I uninstalled steam I was able to run the command.
But it told me to run ‘sudo mkinitcpio -P’ manually afterwards, since it exited with non-zero.
I did that and it told me that it can’t find the things I added after MODULES in the /etc/mkinitcpio.conf config.
Once I removed those, I was able to run the mkinitcpio command.
After rebooting though I didn’t even get to the login screen.
I just had a blank screen with a blinking cursor in the top left corner.
When I installed the nvidia driver again, I got my login screen back, but it’s still going dark after I log in.
Any other ideas?

Are you able to boot on the live ISO and connected to internet post the following link to

inxi -Faz --no-host | eos-sendlog

Edit: What desktop do you have installed also?

I used the offline xfce installation beginning last year.
I’ll work on creating a new live usb stick and then post the information you requested.
Thanks for your help.

Hi @ricklinux,
The output of your command went here:
https://clbin.com/xM7sT

Okay i see you are using xfce with lightdm. Have you added the lightdm graphical check under troubleshooting in the wiki on this page.

Edit: Sorry you are having this trouble. I have an Nvidia GTX 1060 on Xfce.

Just in case the wiki doesn’t tell you where the file is exactly. Use a text editor to edit the file.

/etc/lightdm/lightdm.conf

Uncomment and set true

logind-check-graphical=true

I also see you have a number of kernel parameters. Did you add them yourself? I don’t see that they would be necessary. Our current iso on the default entry will boot and install Nouveau opensource driver if you have nvidia. Otherwise you select non-free entry and it will install Nvidia drivers if you have nvidia.

Anyway i see these.

nvidia nouveau.modeset=0 nouveau.blacklist=yes 
           modprobe.blacklist=nouveau i915.modeset=1 radeon.modeset=1 

Thanks for all your input @ricklinux ! Really appreciate it.

OK, I don’t recall making a specific choice about the display manager when choosing XFCE. What are you using instead of lightdm?

I changed the config to say

logind-check-graphical=true

But it did not change the behavior. I also read on the discovery page for lightdm you provided that not having set this would cause the screen to stay black before the login screen even comes. But that’s not the case. I see the desktop with the login screen. It’s just that after entering the password to login the screen goes black and stays like that (no Signal is sent to the monitor anymore).

So I then retried ‘sudo nvidia-installer-dkms -n’ route, since in that case I didn’t even get a login screen. But this didn’t change that either.

I do not recall setting the kernel parameters you listed. Can one or multiple of them cause the nouveau driver not working properly (getting the blinking cursor in the top left screen instead of a login screen)?

Are you suggesting to remove these somehow?

Edit: am I in the wrong group here? Should I rather post my issue in a lightdm group in the forum?

No you are fine. Could you just verify the default grub by posting the link to this. I’ll check it first.

cat /etc/default/grub | eos-sendlog

Edit: Lightdm is the default desktop display manager for Xfce.

Also currently there has been another kernel update and other updates so you might want to just log into a TTY and update

sudo pacman -Syu

See if you can boot on the new kernel after updates.

on Telegram also got some people with lightd issues, sudo mkinitcpio -P seemed to help.

What is strange is he would have done that installing the nvidia drivers again and still didn’t work. But why not try again if the kernel update doesn’t work.

Edit: I don’t understand why this happens. I never seem to get it on my nvidia with xfce. :thinking:

multiple things can be offcourse, but mkinitcpio helps generating kernel modules, somehow it didnt, its a possibility. first of all try to run tty ctrl-alt-f2 as example. if possibke get a linux-lts you can see also if its kernel related on somepoint.

@marcelicious
You could first try my suggestion to update and install the lastest kernel and updates. If the doesn’t work you could try as @ringo suggests the lts kernel.

sudo pacman -S linux-lts linux-lts-headers

1 Like

in some cases the ~/.Xauthority can be the issue… and it can help moving it out of the way…
mv ~/.Xauthority ~/old.Xauthority and restart lightdm: sudo systemctl restart lightdm