After installing the Decentraleyes Firefox addon my EndeavourOS install is reported as Windows 10

This is the addon

After installing this addon my EndeavourOS install is getting reported as Windows 10. I first noticed this on another Linux forum I visit. That forum has a feature that shows an small icon of the OS the member is using. To confirm this I visited this website and found its clearly says Windows 10.

os

Anyone here familiar with Decentraleyes ? Is this normal ? I installed this addon just 4-5 days ago after reading that it enhances privacy. Its also “recommended” by Mozilla.

Are you sure it is decentraleyes?

There are a lot of privacy tools that do this. I think enabling anti-fingerprinting in Firefox will do this as well. The idea is if you identify as linux it is much easier to track/fingerprint you.

Almost. This is the list of all addons I am using.

What about firefox settings? Did you use a user.js or enable fingerprint protection in settings?

It is super easy to test. Disable decentraleyes and see if you get the same result when you check your user agent.

No custom user.js in use. I just tested with Decentraleyes disabled & its still says Windows 10.
To be on the safe side I restarted FF after disabling Decentraleyes.
This is my privacy settings

Looks like it is baked into firefox by default now. Decentraleyes has nothing to do with it. Its is just a coincidence you installed it and noticed this behavior at the same time.

More here:

2 Likes

I must say your searching skill is impressive. I too search but couldn’t find that. So there’s nothing to worry about. I will enable Decentraleyes again & continue as usual. Thanks to both of you.

I just created a new firefox profile (ff 90) on my linux pc, added decentraleyes and visited that website, it says “Your OS is Linux 64-bit”, which is correct.

Are you sure your prefs are default? (go to about:config and click “show only modified preferences”)

The list is quite long so can’t post a screenshot. What am I looking at exactly ?
Just curious I am still running Firefox 89. When did you receive that update ?

Now after all this I remember I followed most of the tweaks mentioned here.
I did that on exactly 30th September 2020. Right after I finished installing EndeavourOS.

Now if those tweaks are responsible for this or what @Elloquin has mentioned, that I am not sure of.

Try looking for resistfingerprinting, useragent…

I think I got the update yesterday, to see if there is an update go to the help menu > “about firefox”.

You have resistFingerprinting on then, that’s changing your user agent. If you set it to false, that website should report your true OS.

Okay.

That method works only if you are using the tarball directly from Mozilla’s website. Mine is the repo version.
FF version

I thought you were using the tarball, because the Arch repo has firefox 90.0-1 since yesterday. Have you already tried updating your repos?

Nope. Still the same. Disabled both that setting in about config & Decentraleyes & restarted FF. Still the same. After the reading the links which Elloquin provided I believe this the new default now.

$ sudo pacman -Syu
[sudo] password for home: 
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
 endeavouros is up to date
:: Starting full system upgrade...
 there is nothing to do

Weird… v90 is in the official repo, and I’m using it right now (installed after a pacman upgrade). If useragent spoofing was a FF “feature”, mine should also have been recognized as Windows :thinking:

Firefox blocks fingerprinting

The latest Firefox browser protects you against fingerprinting by blocking third-party requests to companies that are known to participate in fingerprinting. We’ve worked hard to enable this privacy protection while not breaking the websites you enjoy visiting. (Read more here, if you want the technical details.)

And it’s not a deep setting you need to dig around to find. In the latest Firefox browser, fingerprint blocking is the standard, default setting. Visit your privacy protections dashboard to see how you’re being tracked behind the scenes and how Firefox prevents it.

You probably wouldn’t appreciate someone tracking your moves in real life. There’s no reason to accept it online. If you don’t already have Firefox, download and protect yourself from digital fingerprinting.

2 Likes

I am not yet 100% confident about Arch so I am asking is pacman -Syu the correct command ? Do you think I am using mirrors which are not fully synced ? What’s the command that prints the mirrors in use ? That way I can compare mine with yours.

@Elloquin
I am running Firefox 89.0.2. Is there an update pending in my case ?

1 Like

Let me look. OK:
Firefox is currently at 90.0-1

https://archlinux.org/packages/extra/x86_64/firefox/

So yes you have an update coming. You can try refreshing your mirror list with the welcome app and then updating as usual.