After installing Nvidia, "input not supported" & black screen on boot

Hello, I’m just starting out learning linux and it’s been fun learning how to setup and use EndeavourOS. I spent some time setting up a nice desktop environment and decided to download steam and try to get games running.

I installed Nvidia drivers for my specific card (GTX 1070) using the nvidia-inst and rebooted. But on startup all my screen says is “Input not supported”. I’ve tried many things, such as setting ibt=off in kernel boot settings and also downloading the lts kernel. I’ve chroot-ed in from a usb installation and tried to make sure I have all the dependencies by using nvidia-inst -t and doing as it says, but it still wants me to run ‘systemctl disable bumblebeed.service’, yet when I try that it just says ‘Failed to disable unit, unit bumblebeed.service does not exist.’

What’s really odd is the first time I rebooted, I actually had a discord call open and I could hear my friends so i’m sure endeavour actually booted to my desktop, but there’s something wrong with the drivers maybe not using the right resolution, or not properly detecting my screen so it just said “input not supported”. I’m completely clueless on how to fix it if it’s that, as i’ve tried to edit some conf files for xrandr but to no avail.

There’s also another person who managed to fix the ‘input not supported’ problem with basically the same situation i’m in: 1080p75 "Not Supported" by Acer SB220Q Monitor
I have the exact same monitor (Acer SB220Q), but I have no clue how (and if i even should) download the nvidia-510xx-dkms package. I’ve also tried using a different HDMI cable so it’s not that.
Can any of you help with this issue? I really have no idea what else to do just to make it send a proper signal to my screen. It’s been very hard trying to troubleshoot this while being unable to actually get in the system, since the tty terminal doesn’t pop up after boot.

can you report

inxi -Fza 

recheck option for nvida-inst

Sorry, I’m not sure what you mean by recheck option for nvidia-inst. All i really did was run
nvidia-inst --drivers
nvidia-inst --series 525
Since the --drivers flag told me that the proper drivers were for series 525.

Here is my inxi -Fza


Kernel: 5.15.91-4-lts arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
parameters: BOOT_IMAGE=/boot/vmlinuz-linux-lts root=UUID=0167a4d5-a918-41e7-b7c8-946aafb41e0e
rw nowatchdog nvme_load=YES
resume=UUID=0bcd23c1-8a65-469a-b231-55d5215615e2 loglevel=3 ibt=off
Console: tty 1 DM: LightDM v: 1.32.0 Distro: EndeavourOS base: Arch Linux
Type: Desktop Mobo: ASUSTeK model: PRIME B450M-A v: Rev X.0x serial:
UEFI: American Megatrends v: 3802 date: 04/28/2022
Device-1: sony_controller_battery_00:1b:fb:c5:a5:b6 model: N/A serial: N/A charge: N/A
status: full
Info: model: AMD Ryzen 5 2600 bits: 64 type: MT MCP arch: Zen+ gen: 2 level: v3 note: check
built: 2018-21 process: GF 12nm family: 0x17 (23) model-id: 8 stepping: 2 microcode: 0x800820D
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache: L1: 576 KiB
desc: d-6x32 KiB; i-6x64 KiB L2: 3 MiB desc: 6x512 KiB L3: 16 MiB desc: 2x8 MiB
Speed (MHz): avg: 1933 high: 3562 min/max: 1550/3400 boost: enabled scaling:
driver: acpi-cpufreq governor: schedutil cores: 1: 1458 2: 2564 3: 1335 4: 3562 5: 1533 6: 1328
7: 1335 8: 2718 9: 1330 10: 2945 11: 1542 12: 1552 bogomips: 81446
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed mitigation: untrained return thunk; SMT vulnerable
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP: disabled, RSB filling,
PBRSB-eIBRS: Not affected
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Device-1: NVIDIA GP104 [GeForce GTX 1070] vendor: driver: nvidia v: 525.89.02
alternate: nouveau,nvidia_drm non-free: 525.xx+ status: current (as of 2023-02) arch: Pascal
code: GP10x process: TSMC 16nm built: 2016-21 pcie: gen: 1 speed: 2.5 GT/s lanes: 16 link-max:
gen: 3 speed: 8 GT/s bus-ID: 08:00.0 chip-ID: 10de:1b81 class-ID: 0300
Display: server: v: driver: X: loaded: nvidia gpu: nvidia tty: 240x67
API: OpenGL Message: GL data unavailable in console. Try -G --display
Device-1: NVIDIA GP104 High Definition Audio vendor: driver: snd_hda_intel
bus-ID: 1-2:2 v: kernel chip-ID: 0c76:161f pcie: class-ID: 0300 gen: 1 speed: 2.5 GT/s lanes: 16
link-max: gen: 3 speed: 8 GT/s bus-ID: 08:00.1 chip-ID: 10de:10f0 class-ID: 0403
Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel pcie: gen: 3
speed: 8 GT/s lanes: 16 bus-ID: 0a:00.3 chip-ID: 1022:1457 class-ID: 0403
Device-3: JMTek LLC. USB PnP Audio Device type: USB driver: hid-generic,snd-usb-audio,usbhid
Sound API: ALSA v: k5.15.91-4-lts running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.65 running: no
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK PRIME B450M-A
driver: N/A modules: r8169 pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 07:00.0
chip-ID: 10ec:8168 class-ID: 0200
Local Storage: total: 2.07 TiB used: 1.51 TiB (73.2%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD20EZBX-00AYRA0 size: 1.82 TiB
block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial:
rev: 1A01 scheme: MBR
ID-2: /dev/sdb maj-min: 8:16 vendor: PNY model: CS900 240GB SSD size: 223.57 GiB block-size:
physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: rev: 0B12 scheme: GPT
ID-3: /dev/sdc maj-min: 8:32 type: USB vendor: HP model: x702w size: 29.76 GiB block-size:
physical: 512 B logical: 512 B type: N/A serial: rev: 1.00 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
ID-1: / raw-size: 41.09 GiB size: 40.15 GiB (97.71%) used: 12.86 GiB (32.0%) fs: ext4
dev: /dev/sdb7 maj-min: 8:23
ID-2: /boot/efi raw-size: 1024 MiB size: 1022 MiB (99.80%) used: 316 KiB (0.0%) fs: vfat
dev: /dev/sdb5 maj-min: 8:21
Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 7.91 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sdb6
maj-min: 8:22
System Temperatures: cpu: 31.0 C mobo: N/A gpu: nvidia temp: 36 C
Fan Speeds (RPM): N/A
Processes: 280 Uptime: 1m wakeups: 1 Memory: 15.53 GiB used: 622.6 MiB (3.9%) Init: systemd
v: 252 default: graphical tool: systemctl Compilers: gcc: 12.2.1 Packages: pm: pacman pkgs: 999
libs: 247 tools: yay Shell: Bash (login) v: 5.1.16 running-in: tty 1 inxi: 3.3.25

can you report xrandr ?

I can’t, unless there’s a method of doing that that i’m not aware of? Since I can’t actually get into the system I either have to boot into my system without a graphical interface through a kernel setting, or chroot in. Both of which make xrandr simply spit out “Can’t open display”. If I boot normally and try to hit ctrl+alt+f3 to open tty terminal while the screen says “input not supported”, the screen flashes black for a second, then just goes back to “input not supported”.

xrandr -d :0 -q
inxi --display :0 -Gaz
xrandr -d :0 --auto

Sorry for late reply. I tried both
xrandr -d :0 -q
xrandr -d :0 --auto
but both just output “Can’t open display :0” when i type them into the terminal.

inxi --display :0 -Gaz basically just outputs what the other inxi I posted did:


Device-1: NVIDIA GP104 [GeForce GTX 1070] vendor: driver: nvidia v: 525.89.02
alternate: nouveau,nvidia_drm non-free: 525.xx+ status: current (as of 2023-02) arch: Pascal
code: GP10x process: TSMC 16nm built: 2016-21 pcie: gen: 1 speed: 2.5 GT/s lanes: 16 link-max:
gen: 3 speed: 8 GT/s bus-ID: 08:00.0 chip-ID: 10de:1b81 class-ID: 0300
Display: server: v: driver: X: loaded: nvidia gpu: nvidia
API: OpenGL Message: No GL data found on this system.

This means Xorg server is not running. I hoped it was only a monitor issue. You may check running tasks to see if X is running.

pgrep -a Xorg

But I suppose it won’t, since you targeted TTY on boot.
I am sorry for the confusion.

OTOH, in another topic, the backlight is suspected. Without video drivers, I suppose no backlight is active, so… :person_shrugging:

In any case, there is no troubleshooting without logs.
You should get journal and Xorg logs of the failed boot sessions.

I apologize, I’m pretty new and wasn’t sure what exactly I’d need to post or how to do it. I tried “pgrep -a Xorg” and nothing happened in the TTY terminal.

I ran

journalctl -b -0

and uploaded the output to

after I booted normally and let it sit for a minute, I grabbed and uploaded my /var/log/Xorg.0.log file to

If there’s any more logs that’d help I’d be happy to grab some more.

Try using these kernel parameters during next boot, modifying boot menu command line:

nomodeset nouveau.modeset=0

If it boots fine, set them permanently in a configuration file, depending on your bootloader (grub, systemd-boot).

If there is no improvement, have a look at Archwiki nvidia troubleshooting for more ideas.

I tried using that parameter and nothing changed. I also tried using the nvidia_drm.modeset=1 and it just made the “input not supported” screen happen faster on boot.

Looking through the nvidia troubleshooting page, I tried changing xorg config settings as per #10 no useable config and also tried to add a ConnectedMonitor or UseDisplayDevice option to both Screen and device settings in xorg.conf but it just hung indefinitely on the staring graphical interface on boot. Same issue occurs if I try to add nvidiaXineramaInfo, nvidiaXineramaInfoOrder, or nvidiaXineramaInfoOverride to the options in xorg.conf while using “DFP-1” as the values (since my xorg.0.log seems to say that’s what it’s identifying my screen as).

Since it seems it could’ve been defaulting to the other port on my GPU, which was a DVI port, I tried plugging into that as well but it didn’t change anything.

I also tried all the options at #11 blackscreen at X startup but none of these really changed anything. Still had ‘input not supported’

I also tried using nvidia-settings to try and automatically set xorg settings but if I try to use it in tty, chroot, or proot, it just spits out that it ‘can’t find display’

I already tried just reinstalling the entire OS but that didn’t change anything either. I really don’t know what else to try, but thank you for the suggestions.

1 Like

There is a storm of Xorg/video drivers issues lately, that I wonder if some evil Corp has done any tricky cracking attack to Archlinux… :face_with_head_bandage:

I have also the impression that latest hardware (laptops, monitors, etc.) have new firmware/protocols modifications that are still not healed by the kernel devs.

I can’t say which of the two is closer to the facts… :person_shrugging:

In your case, it seems the GPU works fine, while the monitor is lacking some communication language to make the touch.
Relevant things can be: Monitor EDID, monitor DPMS/power settings, backlight (vendor’s/kernel’s/monitor’s), some other system component misconfigured (systemd service, Xorg option, kernel parameter, etc.).

Since you boot to TTY, and Xorg log looks fine (no errors), what if you start the display manager and get some errors?

sudo systemctl start display-manager

About your troubleshooting, it looks awesome for a new Linux user! :+1:

Nevertheless, the things you tried can be easily misunderstood as for the correct implementation (files modified, commands run, etc.). If not a big deal, could you post more details about what and how?

1 Like

haha I used to take computer science classes but eventually dropped out years ago. It’s been a very long time since I touched a terminal and even back then I rarely did anything with Linux outside of classwork. So technically not a total newbie but I’m definitely a far cry from endeavourOS’ intended ‘intermediate users’ I guess.

Anyways, I think I managed to (mostly) fix my problem thanks to you! I took another look at how I was writing the options for the xorg config file and I was typing them without quotes. And, after messing with the Xorg.conf file a lot, it seems the issue was with the EDID of my monitor, or at least the refresh rate that the display manager pulls… I’m not sure if the EDID is wrong, or xorg/nvidia was reading it wrong, but I used an option in the xorg.conf file to just disable it.
Under Section “Screen” in the /etc/X11/xorg.conf file put:

Option         "UseEDID" "FALSE"

This finally got me onto my desktop, albeit at a really bad resolution. From there I just used the terminal and ran “sudo nvidia-settings”, went to Display Config, changed settings to what i needed, and then clicked ‘Save to X Configuration File’ and merged the file.

The only problem now is when I go to shutdown my machine, the shutdown process makes “Input not Supported” pop up again for a few seconds until the pc shuts off. I don’t know if there’s another config file for that or something, since it’s kinda annoying seeing it but at least my linux installation is usable now. I’ll post my full xorg.config file here so anyone else needing it as an example can read it. There’s a few lines like ModeLine, nvidiaXineramaInfoOrder, nvidiaXineramaInfoOverride, and UseDisplayDevice that may not be necessary, but was part of my troubleshooting process.


#nvidia-xconfig: X configuration file generated by nvidia-xconfig
#nvidia-xconfig: version 525.89.02

Section “ServerLayout”
Identifier “Layout0”
Screen 0 “Screen0” 0 0
InputDevice “Keyboard0” “CoreKeyboard”
InputDevice “Mouse0” “CorePointer”
Option “Xinerama” “0”

Section “Files”

Section “InputDevice”
# generated from default
Identifier “Mouse0”
Driver “mouse”
Option “Protocol” “auto”
Option “Device” “/dev/psaux”
Option “Emulate3Buttons” “no”
Option “ZAxisMapping” “4 5”

Section “InputDevice”
# generated from default
Identifier “Keyboard0”
Driver “kbd”

Section “Monitor”
Identifier “Monitor0”
VendorName “Unknown”
ModelName “DFP-1”
DisplaySize 1920 1080
HorizSync 54.0 - 85.0
VertRefresh 48.0 - 75.0
ModeLine “1920x1080R” 138.50 1920 1968 2000 2080 1080 1083 1088 1111 +hsync -vsync
Option “PreferredMode” “1920x1080R”
Option “DPMS”

Section “Device”
Identifier “Device0”
Driver “nvidia”
VendorName “NVIDIA Corporation”
BoardName “NVIDIA GeForce GTX 1070”

Section “Screen”
Identifier “Screen0”
Device “Device0”
Monitor “Monitor0”
DefaultDepth 24
Option “UseDisplayDevice” “DFP-1”
Option “nvidiaXineramaInfoOverride” “1920x1080+0+0”
Option “UseEDID” “FALSE”
Option “Stereo” “0”
Option “nvidiaXineramaInfoOrder” “DFP-1”
Option “metamodes” “1920x1080R +0+0; nvidia-auto-select +0+0”
Option “SLI” “Off”
Option “MultiGPU” “Off”
Option “BaseMosaic” “off”
SubSection “Display”
Depth 24

1 Like

According to Archwiki, nvidia does not use invalid modes, so a bad monitor implementation is like no modes at all. Disabling this with UseEDID false, (or setting the refresh rate, or the combination) allows Xorg to guess, which resurrects the monitor. This (guessing) seems to be the default behavior of Xorg/modesetting, and makes open source video drivers usually more successful.

Then you might welcome some tips :wink: .

Use /etc/X11/xorg.conf.d/*.conf instead (deleting the former).

Arch devs and Xorg typically have such defaults (/usr/lib/*/*) that mostly work successfully OOTB. Keeping self-created (addon) files contents to a minimum helps keeping maintenance simple and confident about which directives actually work (as an additional to upstream defaults).
In this case, a minimal .conf with one or two sections might do the job. As you assumed, UseEDID=false and/or resolution set, should be enough, but it may need a proper home to work.

Such content is preferred to be posted in code format, keeps tabs and spaces, which makes it easily readable. No need to hide it, since it is auto-fitted in a window.

Have fun with Arch and EnOS! :wink:

1 Like