1080p75 "Not Supported" by Acer SB220Q Monitor

I have been using the Acer SB220Q monitor for a couple years now as an additional display for my HP Pavilion gaming laptop. Its maximum supported resolution is 1080p at 75 Hz.

When I first switched to Linux (first Manjaro, and now Endeavour OS, both with KDE), I was able to use the 1080p75 setting on my monitor with no inherent issues. However, after a recent update (specifically one I applied on May 14th), my monitor now only displays “Input Not Supported” when I set it to display 1080p75. Though, the screen resolution still changes, so I can move my mouse over and interact with windows unseen to me. However, the monitor can display anything below that setting, both for resolution or refresh rate, including 1080p60, 1050p75, 900p75, and so on.

I am using an NVIDIA GTX 1050 Ti Mobile with the proprietary NVIDIA drivers. I’m not sure which update caused this issue (probably the NVIDIA drivers or Linux kernel, but I can’t be sure), and am wondering if anyone else with an NVIDIA card has similar issues with the same or different monitor, as well as how it could be fixed. I should mention that I dual boot Windows 11 on this laptop, and 1080p75 works fine on that installation.

My inxi -Fazy:

  Kernel: 5.18.1-arch1-1 arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux
    root=UUID=d394ca26-cf4e-441f-811c-58ab0c780669 rw rootflags=subvol=@
    root=/dev/mapper/luks-60513ba7-f282-4199-aea3-d12d4151126a loglevel=3
    nowatchdog nvme_load=YES
  Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.4 info: latte-dock
    wm: kwin_x11 vt: 1 dm: SDDM Distro: EndeavourOS base: Arch Linux
  Type: Laptop System: HP product: HP Pavilion Gaming Laptop 15-cx0xxx
    v: Type1ProductConfigId serial: <superuser required> Chassis: type: 10
    serial: <superuser required>
  Mobo: HP model: 8478 v: 70.60 serial: <superuser required> UEFI: Insyde
    v: F.26 date: 08/10/2021
  ID-1: BAT1 charge: 56.3 Wh (100.0%) condition: 56.3/52.2 Wh (107.9%)
    volts: 12.1 min: 11.6 model: Hewlett-Packard PABAS0241231 type: Li-ion
    serial: <filter> status: full
  Device-1: sony_controller_battery_1c:a0:b8:9d:aa:f0 model: N/A serial: N/A
    charge: N/A status: full
  Info: model: Intel Core i5-8300H bits: 64 type: MT MCP arch: Coffee Lake
    family: 6 model-id: 0x9E (158) stepping: 0xA (10) microcode: 0xF0
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 802 high: 814 min/max: 800/4000 scaling:
    driver: intel_pstate governor: powersave cores: 1: 800 2: 800 3: 802 4: 803
    5: 800 6: 800 7: 814 8: 803 bogomips: 36812
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: Hewlett-Packard
    driver: i915 v: kernel ports: active: eDP-1 empty: DP-1,HDMI-A-1
    bus-ID: 00:02.0 chip-ID: 8086:3e9b class-ID: 0300
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile]
    vendor: Hewlett-Packard driver: nvidia v: 515.43.04
    alternate: nouveau,nvidia_drm non-free: 515.xx+
    status: current (as of 2022-05) arch: Pascal pcie: gen: 3 speed: 8 GT/s
    lanes: 16 ports: active: none off: HDMI-A-2 empty: none bus-ID: 01:00.0
    chip-ID: 10de:1c8c class-ID: 0300
  Device-3: Logitech HD Pro Webcam C920 type: USB
    driver: snd-usb-audio,uvcvideo bus-ID: 1-2.1:6 chip-ID: 046d:082d
    class-ID: 0102 serial: <filter>
  Device-4: AVerMedia Live Gamer MINI type: USB
    driver: snd-usb-audio,uvcvideo bus-ID: 1-2.2:11 chip-ID: 07ca:3311
    class-ID: 0102 serial: <filter>
  Device-5: Quanta HP Wide Vision HD Camera type: USB driver: uvcvideo
    bus-ID: 1-5:8 chip-ID: 0408:5300 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.3 compositor: kwin_x11 driver: X:
    loaded: modesetting,nvidia gpu: i915,nvidia,nvidia-nvswitch display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1013x285mm (39.88x11.22")
    s-diag: 1052mm (41.43")
  Monitor-1: HDMI-A-2 mapped: HDMI-0 note: disabled pos: primary,left
    model: Acer SB220Q serial: <filter> built: 2019 res: 1920x1080 dpi: 102
    gamma: 1.2 size: 476x268mm (18.74x10.55") diag: 546mm (21.5") ratio: 16:9
    modes: max: 1920x1080 min: 640x480
  Monitor-2: eDP-1 mapped: eDP-1-1 pos: right model: BOE Display 0x07a1
    built: 2016 res: 1920x1080 hz: 60 dpi: 142 gamma: 1.2
    size: 344x193mm (13.54x7.6") diag: 394mm (15.5") ratio: 16:9
    modes: 1920x1080
  OpenGL: renderer: NVIDIA GeForce GTX 1050 Ti/PCIe/SSE2
    v: 4.6.0 NVIDIA 515.43.04 direct render: Yes
  Device-1: Intel Cannon Lake PCH cAVS vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl
    bus-ID: 00:1f.3 chip-ID: 8086:a348 class-ID: 0403
  Device-2: NVIDIA GP107GL High Definition Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:0fb9 class-ID: 0403
  Device-3: Sony DualShock 4 [CUH-ZCT2x] type: USB
    driver: snd-usb-audio,sony,usbhid bus-ID: 1-1.1:4 chip-ID: 054c:09cc
    class-ID: 0300
  Device-4: Logitech HD Pro Webcam C920 type: USB
    driver: snd-usb-audio,uvcvideo bus-ID: 1-2.1:6 chip-ID: 046d:082d
    class-ID: 0102 serial: <filter>
  Device-5: AVerMedia Live Gamer MINI type: USB
    driver: snd-usb-audio,uvcvideo bus-ID: 1-2.2:11 chip-ID: 07ca:3311
    class-ID: 0102 serial: <filter>
  Device-6: JMTek LLC. USB PnP Audio Device type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-2.3:12 chip-ID: 0c76:161e
    class-ID: 0300
  Sound Server-1: ALSA v: k5.18.1-arch1-1 running: yes
  Sound Server-2: PulseAudio v: 16.0 running: no
  Sound Server-3: PipeWire v: 0.3.51 running: yes
  Device-1: Intel Cannon Lake PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:a370 class-ID: 0280
  IF: wlan0 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Hewlett-Packard driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: 3000 bus-ID: 04:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IF-ID-1: virbr0 state: down mac: <filter>
  Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB
    driver: btusb v: 0.8 bus-ID: 1-14:10 chip-ID: 8087:0aaa class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: disabled
    rfk-block: hardware: no software: no address: see --recommends
  Local Storage: total: 709.84 GiB used: 332.75 GiB (46.9%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
    model: SSD 970 EVO Plus 250GB size: 232.89 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 2B2QEXM7 temp: 43.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 850 PRO 256GB
    size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 4B6Q scheme: GPT
  ID-3: /dev/sdb maj-min: 8:16 type: USB vendor: JMicron Tech model: N/A
    size: 238.47 GiB block-size: physical: 4096 B logical: 512 B type: N/A
    serial: <filter> rev: 0504 scheme: MBR
  ID-1: / raw-size: 232.59 GiB size: 232.59 GiB (100.00%)
    used: 144.59 GiB (62.2%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-60513ba7-f282-4199-aea3-d12d4151126a
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 724 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 232.59 GiB size: 232.59 GiB (100.00%)
    used: 144.59 GiB (62.2%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-60513ba7-f282-4199-aea3-d12d4151126a
  ID-4: /var/log raw-size: 232.59 GiB size: 232.59 GiB (100.00%)
    used: 144.59 GiB (62.2%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-60513ba7-f282-4199-aea3-d12d4151126a
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: file size: 512 MiB used: 0 KiB (0.0%) priority: -2
    file: /swap/swapfile
  System Temperatures: cpu: 63.0 C pch: 59.0 C mobo: 27.8 C gpu: nvidia
    temp: 52 C
  Fan Speeds (RPM): N/A
  Processes: 327 Uptime: 39m wakeups: 2 Memory: 15.52 GiB
  used: 4.7 GiB (30.3%) Init: systemd v: 251 tool: systemctl Compilers:
  gcc: 12.1.0 Packages: 1455 pacman: 1441 lib: 421 flatpak: 14 Shell: Bash
  v: 5.1.16 running-in: alacritty inxi: 3.3.16

It would be useful to list exactly which packages were updated. You can find that in /var/log/pacman.log file:

grep 2022-05-14 /var/log/pacman.log

If it is indeed update-related, it is probably a temporary annoyance that will be fixed in the next update. It is still a good idea to investigate it, though.

Welcome to the forum!

After checking which packages were updated on that date with your helpful command, I’m leaning on this being an issue regarding the NVIDIA drivers, specifically 515.43.04-1. Coming from 510.68.02-1, that was the version that I updated to on that date. Meanwhile I had also updated the Linux kernel from 5.17.5 to 5.17.7 at the same time. Considering the update to the NVIDIA drivers seems to be more major than the Linux kernel, Iogic tells me that may be where the fault lies.

However, I tried downgrading the drivers and kernel to the versions I had before the update, and temporarily uninstalled Optimus Manager for good measure, but upon rebooting it wouldn’t even detect the second screen at all, so the virtual screen wouldn’t expand and I couldn’t move my cursor to it. Maybe I needed to downgrade more packages than nvidia, nvidia-settings, nvidia-utils, linux, and linux-kernel to get it to work properly, but I’m not sure which specific ones.

Intel Core i5-8300H
UHD Graphics 630
GeForce GTX 1050 Ti Mobile

looks like the combination known to cause issues on 515.43 ?

515.48.07 is in testing, I suspect this issue will resolve itself in due course.

or … using this one till production version of 515 is up and running :wink:

I’ll play the role of ‘totally useless help desk agent’ and ask if you checked the HDMI/DPI/Other cable you are using, made sure both ends are fully connected, etc, etc, etc? I know it’s not likely that the cable came loose or a connection was affected by oxidation at the same time you applied updates, but it should be relative easy to check just for the sake of ruling out any physical cause.

I have tried swapping out different cables, and they made no difference.

It worked! After installing the drivers you provided, my monitor is now compliant with 1080p75. Thanks for letting me know about that package.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.