After a very (2 years or more) late update, can't even load GRUB menu

Hi! just updated a computer that hadn’t updated in 2 years or so (sorry, not my fault), hay a few issues with PGP and keyrings, I fixed them and everything went ok and then (obviously) suggested to reboot.

I did so and after the “welcome to grub” message, screen goes black and system reboots… any ideas on how I could fix this?


It would have gotten a new updated grub package. If you are able to log into a tty then you could try installing the new grub package and then run the grub update command. If you can log in to a tty as root and then run


Hopefully no errors and then

sudo grub-mkconfig -o /boot/grub/grub.cfg

Edit: This may or may not fix the issue.

I can’t log to a tty but will try to do this with chroot as described here

and then report back.

1 Like

Could be as simple as listed here: Attention grub update - #11 by dalto

sudo grub-install --no-nvram
sudo grub-mkconfig -o /boot/grub/grub.cfg

but grub-install may require other parameters…

1 Like

ok, did what @manuel told me but it seems it does require other parameters, as now I do get the GRUB menu but after choosing the menu entry, it goes:

Loading kernel linux ...
error: symbol `grub_is_shim_lock_enabled' not found.
Loading initial ramdisk ...
error: symbol `grub_is_shim_lock_enabled' not found.

Press any key to continue...

EDIT: I also noted before entering GRUB menu, it briefly says:

error: no server specified
error: no suitable video mode found

Check if it’s booting from proper drive since reinstalling grub.

How do I check that? I tried chrooting again and now doing

grub-install --no-nvram --disable-shim-lock
sudo grub-mkconfig -o /boot/grub/grub.cfg

but problem persists.

Just check in the bios which disc is the boot disc. Usually it’s the last entry that shows boot disc priority is the one i mean.

In the chroot, try reinstalling the package grub, do just a simple grub-install and regenerate your grub.cfg:

pacman -S grub
grub-mkconfig -o /boot/grub/grub.cfg

Let’s see if this helps :crossed_fingers:t5:

There are two entries…

  1. EFI File Boot 0: manjaro
  2. Linpus lite

I’ve tried both but same thing happens (probably one doesn’t work so it goes to the next one.
number 1 I guess says manjaro inheriting that name from an old manjaro I installed on this computer before installing Endeavour OS.

Did you try chrooting again and doing as @pebcak suggested in post #9

Edit: This will install the latest grub package. Then you install grub and run the update grub command. It is possible it lost the UEFI entry for booting EOS.

What efibootmgr show grub-install wil give a different name too

I am working right now on what @pebcak suggested in post #9. Will report back soon.

ok but does this mean I should do something?

I think what @ringo means is sometimes the boot disk entry that i mentioned may change in name. So it could be called endeavouros as an example. This is the boot disk priority that i was talking about. Usually you set the boot devices and then you set the boot priority in UEFI Bios.

Edit: As an example from my UEFI Bios settings screen

Edit: So you look in the last entry which is boot disk priority.

2 years back endeavour installs of bootloaderd got nr’s with grub-install simply endeavouros from osrelease…sometimes order is wicked as nvram can growth overtime

1 Like

if I
sudo pacman -S grub

(from chroot), it says

grub-2:2:2.12-1 is up to date --reinstalling

So I imagine there will be no difference at all by doing this?

Just checking because if there is something else to try I prefer not to reboot system and do all the hassle to chroot again to try something else :slight_smile:


Run the other two commands.

When it is done, run efibootmgr and post the output.

Best way is backup importand stuf reinstall fresh…is atleast fastest. Beside grub there probably where also other changed. Removzl of community etc… Does not means is kot fixable… grub-tools is set hooks need to be gone…but efibootmgr is sure importand to overview it as also on the links above to do basicly clean install new iso is better

ok here goes the full output

Notice some commands I did with sudo and others I forgot (but they gave no error whatsoever)
The pure efibootmgr output is here:

BootCurrent: 0003
Timeout: 0 seconds
BootOrder: 0000,2001,0001,2002,2003
Boot0000* endeavouros   HD(1,GPT,0e1e056b-a725-1849-856c-d01350bdbc57,0x1000,0x96000)/\EFI\endeavouros\grubx64.efi
Boot0001* Unknown Device: DA4128        PciRoot(0x0)/Pci(0x1c,0x0)/Ctrl(0x0)/Unit(0)/HD(1,GPT,0e1e056b-a725-1849-856c-d01350bdbc57,0x1000,0x96000)RC
Boot0002* manjaro       PciRoot(0x0)/Pci(0x15,0x0)/USB(3,0)/HD(1,MBR,0xaacc,0x800,0x3a39800)/\efi\efi\boot\bootx64.efi4130312009ae
Boot0003* USB HDD: SanDisk      PciRoot(0x0)/Pci(0x15,0x0)/USB(2,0)/HD(1,MBR,0x4e4305b5,0x4d5940,0x4e800)RC
Boot0005* manjaro       PciRoot(0x0)/Pci(0x15,0x0)/USB(3,0)/HD(1,MBR,0xaacc,0x800,0x3a39800)/\efi\efi\boot\bootx64.efi4130312009ae
Boot2001* EFI USB Device        RC
Boot2003* EFI Network   RC
1 Like