Add/Remove Software?

I just discovered the Endeavour OS by accident when I was on Arcolinux forum. I have tried all Arch based KDE systems, and I primarily use Manjaro KDE, and Arcolinux KDE. I never looked into Endeavour, because the information on Distrowatch only indicates Xfce, and doesn’t mention Plasma or anything else. I only use Plasma, so I didn’t know Endeavour offered Plasma. In any case I just installed the Plasma, but I don’t see any Add/Remove software program software similar to Manjaro and Arcolinux except the “Discover”! I can type pacman in krunner, but when I nothing happens when I try to run it. Am I missing something?

P.S. Needless to say that someone needs to update the Dristowatch information.

Endeavour should ship with both pacman and yay which are command line package managers. If you would like to use the “Add/Remove software” seen in some other distributions that is called pamac and can be installed from the AUR using yay

1 Like

Hi @fhins, welcome to EndeavourOS. :rocket:

it’s not us who update Distrowatch information…In hoping it will be done on the next ISO to inform about DE possibilities and more…

To add or remove new software simply :

sudo pacman -S package_name
sudo pacman -R package_name

Have a look on our wiki :

@FLVAL
What is command line to install the “add/remove” program? I can’t seem to make it work!
Thanks,

yay -Syu pamac-gtk

That will update your system and install it. It might take a little while as it will build it from source.

Everyone mentioned pacman. I removed it from my system. Yay uses the same switches pacman does, and yay -Syu polls the packages, and then the AUR a well. Yay does it all! :wink:

Since yay can’t work without components of pacman, how did you remove pacman from your system? Wouldn’t removing pacman take basically take the entire system with it since base depends on pacman?

yay -Rns (then it asks for your password).

As I said, I removed pacman, and yay works like a charm. The system wouldn’t have let me remove pacman had it been a dependency for yay.

yay is a pacman wrapper. And it does depend on it.
https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=yay

Maybe you mean pamac?

Yay is written with Go. No, pacman. I’m not kidding. Try yay -Syu and see what it does.

and? :thinking:

I get an error: Could not find all required packages.

[fred@Endeavouros ~]$ yay -Syu pacman-gtk
[sudo] password for fred: 
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
 endeavouros              11.6 KiB   578 KiB/s 00:00 [----------------------------] 100%
:: Starting full system upgrade...
 there is nothing to do
:: Searching databases for updates...
:: Searching AUR for updates...
==> Error: Could not find all required packages:
    pacman-gtk (Target)

pamac-gtk or pamac-aur or pamac-aur-git the choice is yours

pamac-tray-appindicator plasma

You have a typo in your initial command. I know pamac and pacman are very similar names.

You are confusing pacman with pamac. Your command should be to install pamac. yay -Syu pamac-gtk
Pacman is part the Arch installaton. Pamac is a GUI tool for pacman.

Edit: Like @JR29 said you have a choice to install pamac-aur pamac-aur-git or pamac-gtk

and for plasma, you need pamac-tray-appindicator

1 Like

I’ll be darn, I learned something totally new, and it worked! What a great community!

Thanks to All!

1 Like

Except you totally can’t do this because pacman is needed by so many packages. If you try, you will get something similar to this.

>> yay -Rns pacman                                                                                                                                                                                                                                                                                                                                             
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing pacman breaks dependency 'pacman' required by base
:: removing pacman breaks dependency 'pacman' required by expac
:: removing pacman breaks dependency 'pacman' required by pacman-contrib
:: removing pacman breaks dependency 'pacman>=5.0' required by pyalpm
:: removing pacman breaks dependency 'pacman>=5.2' required by yay

It is and it doesn’t. Here is what yay says about itself. Take a look at dependencies:

yay -Si yay
Repository      : endeavouros
Name            : yay
Version         : 9.4.6-2
Description     : Yet another yogurt. Pacman wrapper and AUR helper written in go.
Architecture    : x86_64
URL             : https://github.com/Jguer/yay
Licenses        : GPL
Groups          : None
Provides        : None
Depends On      : pacman>=5.2  sudo  git
Optional Deps   : None
Conflicts With  : None
Replaces        : None
Download Size   : 2.18 MiB
Installed Size  : 6.26 MiB
Packager        : EndeavourOS <info@endeavouros.com>
Build Date      : Sun 01 Mar 2020 08:03:04 AM CST
Validated By    : MD5 Sum  SHA-256 Sum  Signature

You seem to be confused here. Just because it is written in go, doesn’t mean anything about its dependencies. It is just calling pacman and/or libalpm(which is part of pacman).

I am not trying to argue with you for fun here but telling people to remove pacman is a really bad idea. Because, it is probably possible, but it would break your system in a way that wouldn’t be super fun to fix.

5 Likes