Access to a (Win) filesystem - with the Endeavour-Live-DVD -

Hello dear Endeavour community, :grinning: :grinning:

Wants to access a file system with an Endeavour Linux Live DVD

So it’s like this: a Win 10 computer (a slightly older Lenovo notebook) no longer boots up properly - what would you do here. He can’t even run the onboard repair system anymore.
Well, there’s still data to back up. - before a Linux comes on it.

How exactly do I proceed: It should be possible to do that with an Endeavour version, a LIVE DVD, right!? Do I always need a Knoppix and its toolset here?

for data rescue - i.e. backing up the data that is still on it: I think that - if I start the computer with an Endeavour Linux Live 'DvD then I should (just like basically with any other Linux life system) then be able to read the data, especially if the NTFS can be mounted and the partition table is still intact.

How do you see that!? :grinning:

In the past it was possible, I also used knoppix. I believe that windows set so many security barriere, that probably you won’t be able to access your data outside of windows until it is a share samba folder or similar. But I might be wrong.

1 Like

Not that long ago I needed to access a partition with a unbootable Windows on to recuperate some files. I just used EnOS’ live usb and mounted the device in the file manager. Worked fine.


If Bitlocker drive encryption is enabled, it is near impossible to save any data. If it isn’t enabled, (probably it isnst) the partition should appear and be mountable, depending on the damage the disk has.
@otrott if you have an EndeavourOS media at hand; disable secure boot from firmware interface, boot EndeavourOS and see if anything appears on the file manager.


Hello and good day dear @Zircon34, @pebcak, @mrvictory

many many thanks for the reply - i am very glad to hear from you.

The notebook is a Lenovo G 780 10 years old - with a 1 TB HDD

i tried to get access to the partition - but i had no luck

see the images.

btw;: see a gparted-overview and

note i tried to mount the NTFS with EndeavourOs - and besides that i tried
a MX-Linux. I think that i did something wrong…

What can i do now ?! Look forward to hear from you.





well the question is - how to get the data copied !?

How to do this -…!?

What did you do? Did it on MX linux?

1 Like

Hello dear Ricklinux,
many many thanks - for the quick reply. I tried it with the newest EndeavourOS linux - that is available.

but i ( guess’) that i got stuck somehow!? I was asked for a passwd.
Did i do something worng!? Which steps should i take to

a, mount the drive and
b. copy the data!?

See the image that i have atached.

Finally i tried to test the MX-.Linux MX 21 - but i did not succeed.

Can you advice me what to do!? I look fgoward to hear from you

I don’t think there is a password on the live ISO? User is liveuser…

1 Like

hello dear Ricklinux,

many thanks - i wonder what password-request this is - that we have seen (see the image).
Well - to be frank - do you think that can mount the partition!?

It should be possible - shouldn’t it !?

i have to re-try it. i must try it agian! -

note: If i see the partition -. in gparted the i must be able to

a. mount it
b. to copy it

This is an older laptop. Does it have UEFI or is it Bios? If it is UEFI do you have secure boot disabled?

Edit: 10 years old …hmm probably Bios?

1 Like

hello ricklinux,

many thanks for the quick reply.

it is a Lenovo G 780 - and i have to make sure what is the system

a. UEFI or

i guess that it is BIOS … but i will look and try to find out.

You can check if booted on the live ISO
Edit: What does it output?

sudo efibootmgr
1 Like

Also if you boot on the live ISO can you mount the ntfs partition?

sudo mount /dev/sda2

Not sure if it needs sudo?

1 Like

Also make sure to disable atrocio- i mean fastboot

If you are not comfortable with system administration of this sort then you’re well advised to find some local technical support, e.g. a computer shop, who can copy the data for you.

It’s not worth the risk of you deleting something by mistake when you misinterpret help you receive from people on the forum - who are trying to help you even though copying data from a Windows partition is only very loosely related to EndeavourOS. Or MX Linux for that matter.


hi @ricklinux

sudo efibootmgr

efi variables are not supported on this machine

It’s Bios system then. Looks like you are trying to access an NTFS windows partition. You have to mount the partition /dev/sda2 I’m assuming that’s what you are wanting to do? This post is over a month old so not sure you are still trying to do this?

1 Like

hi there good day dear @ricklinux
many thanks for the quick reply. i only sit in front of this notebook each weekend - so to day i am continuing to save the data. I will have to mount the partition /dev/sda2

i will keep you informed.
Many thanks for all you help _this is an awesome forum - a great place to be


I seems to detect a little rise in aggravation here from your end…

Not being a frog, I can only breathe it away (not just blow it away).




hi there good day ivanhoe


see the image of the gparted here

and is the external hdd not visible in the gparted overview / if so / and if this is correct then i guess that all i have to do is to mount the sda2

note the notebook i am working is the lenovo g 780 with a 1TB hdd / so i hope that what we an see in the gparted overview are the drives

sda 1

sda 2 / which is hopefully the 1TB drive