A start job is running

please enable this service again:
sudo systemctl enable ntpd.service

1 Like

Done, thanks for the help. :smiling_face_with_three_hearts:

2 Likes

I come home, turn on the computer and surprise.

photo5109401784220231720

I follow the instructions on systemd-hostnamed service failed on startup lets see how it goes.

it does say what’s wrong here - you got problems with your lightdm. Just disable it - I don’t use dispaly managers for this reason.
systemctl disable lightdm.service

If you’re thinking of going forward without display manager you can start your session via .xinitrc and use startx (after username and password) to login to the session

There may be a problem currently with lightdm but there are and have been a number of other problems and they seem to change. I don’t think disabling lightdm is the answer or direction to go. If it was me i would have already been checking hardware and testing the memory and probably creating a new ISO and reinstalling.

1 Like

I agree with @ricklinux many weird errors are poping up. I’d also recheck the iso and maybe reinstall the system.

As a last “wild guess” i’d ask which partition size of your system. The only time i had such a “zoombie apocalypse” was installing in small partition, every boot was a weird and desperate moment.

In case you reinstall please use at least 6-8GB to /root partition.

you’re probably right. But it’s fun to solve one puzzle at a time to :wink:

edit: my first install was also some weird stuff going on. since then I’ve installed E on 2 laptops without any issues - so I can only agree - reinstalling might be the way to go (new iso ofc)

Here it is.

Screenshot_2019-08-21_19-45-21

Already tested the SSD and the RAM, no problems detected.

Looks like i need to do that.

One crazy question, maybe its AMD related? Inspiron 7375 with a Ryzen 5 2500U.

yes it is random and now also lightdm fails to start, this is most likely hardware failing.

ago 19 22:16:02 juan-pc kernel: pcieport 0000:00:01.1: AER: Multiple Corrected error received: 0000:00:01.0
ago 19 22:16:02 juan-pc kernel: pcieport 0000:00:01.1: PCIe Bus Error: severity=Corrected, type=Data Link Layer, (Receiver ID)
ago 19 22:16:02 juan-pc kernel: pcieport 0000:00:01.1:   device [1022:15d3] error status/mask=00000040/00006000
ago 19 22:16:02 juan-pc kernel: pcieport 0000:00:01.1:    [ 6] BadTLP

@juanprm Could i i ask you some other questions? This is UEFI system? You have disabled Secure boot in the UEFI Bios and Fast boot? Were you using the AMD Proprietary Video drivers or just the open source Linux drivers? Do you have inxi installed? If not could you install it and run inxi -Fxxc0

Yes, with gpt partition.

No, should i?

Mesa drivers.

Sure, logs.

Secure Boot and Fast Boot should be disabled.

Going to try that :grimacing:

Please try that first. The other thing that i see in the logs you sent to @joekamprad looks like errors possibly related to your m.2 drive. PCIe bus error severe and bad TLP. So this is just a guess? It could be.

The other question i need to ask? Have you made any changes to the UEFI Bios settings or were they set to default settings when you installed Endeavour? Also are you running wireless or is it connected with ethernet?

@joekamprad Please look at the inxi -Fxxc0 log. I do not see the EFI partition /dev/sda1. It shows the drive /dev/sda , and /dev/sda2 / and /dev/sda3 swap. Should it not show /dev/sda1 also? Gparted shows it?

@juanprm Okay so i have looked at the manual for your UEFI settings and i don’t see anything that is an issue other than Secure Boot and Fast Boot. If you still have issues i would recommend creating a new ISO with the latest version and reinstall again. Make sure secure boot and fast boot are off. I would make sure the drive is clean by removing all partitions and start fresh. Make sure you are booting in UEFI mode and installing that way. Look closely at the settings in the installer during install. You have already gone through most of the other things such as testing memory so this is what i would suggest.

ArchWiki say:

Kernel and Grub Parameters

System will be unstable with kernel bellow 4.20, while you have older kernel add this parameters to grub

quiet radeon.dpm=1 acpi_osi=Linux acpi_backlight=vendor amd_iommu=on ivrs_ioapic[4]=00:14.0 ivrs_ioapic[5]=00:00.2 idle=nomwait

you can use grub-customizer to make it easier

The upgrade to kernel 4.20 since raven support if there is problem try linux-amd-ravenAUR and may be you will want to install after linux-amd-raven-headersAUR in order to build DKMS modules.

If you want bleeding edge features and power saving try linux-amd-staging-drm-next-gitAUR with linux-amd-staging-drm-next-git-headersAUR, but keep idle=nomwait since still causes hangups.

You can also use kernel 5.1 without kernel parameters without hangups or bugs, you will just have to ignore the startup warning messages.

SOURCE: Archwiki-Dell_Inspiron_7375

1 Like

Those are my boot options.

photo5114185772197586976 photo5114185772197586977

To create a new booteable ISO, what is the correct way?
Before i was using RUFUS, set UEFI boot and done, in Linux how i do that?

Searching around i found the dd method, like this:

sudo dd bs=4M if=path to iso of=path to usb status=progress oflag=sync

Is this correct?

and to secure clean i found this, Solid state drive/Memory cell clearing
Is secure to follow those instructions?
Sorry for asking too much, i want to be completly sure of what i’m doing.

I use etcher-bin from the AUR. Everyone has there own opinion. I personally haven’t had an issue with it. Why do you want to secure erase your disc? Why not just let Endeavour erase the whole disc and create the partitions and install. Just make sure you are installing UEFI mode. I don’t know what you did before but erase disc and use swap without hibernation.