A start job is running for /dev/tpmrm0 times out

I now have to wait for the start job to timeout after updating my system, disabling TPM fixes the issue but I would rather still have it on, going on fallback has the same issue.

Have you tried using the LTS kernel or maybe even Zen (I would try the LTS first if you haven’t already)

I have already been using Zen, when I change to LTS or the Regular kernel, it still occurs

1 Like

Okay well at least that will rule that out for someone smarter than me

What was updated? If it was the kernel, then does downgrading fix the issue? That would at least solve the issue for now until a solution is found.

How do i show update logs? Also, I already tried the fallback option but it didn’t help either, so it’s not the kernel.

You can use the command paclog | grep upgraded | tail -n 100

Do you know what the fallback does? That isn’t the same as using the older previously working kernel. It uses the same kernel with more modules included. Read more about kernel image creation here https://wiki.archlinux.org/title/Mkinitcpio#Image_creation_and_activation

[2024-06-13T15:32:11+0300] [ALPM] upgraded qemu-system-sparc (9.0.0-1 β†’ 9.0.1-1)
[2024-06-13T15:32:11+0300] [ALPM] upgraded qemu-system-tricore (9.0.0-1 β†’ 9.0.1-1)
[2024-06-13T15:32:11+0300] [ALPM] upgraded qemu-system-xtensa (9.0.0-1 β†’ 9.0.1-1)
[2024-06-13T15:32:11+0300] [ALPM] upgraded qemu-user (9.0.0-1 β†’ 9.0.1-1)
[2024-06-13T15:32:11+0300] [ALPM] upgraded qemu-emulators-full (9.0.0-1 β†’ 9.0.1-1)
[2024-06-13T15:32:11+0300] [ALPM] upgraded qemu-hw-s390x-virtio-gpu-ccw (9.0.0-1 β†’ 9.0.1-1)
[2024-06-13T15:32:11+0300] [ALPM] upgraded qemu-pr-helper (9.0.0-1 β†’ 9.0.1-1)
[2024-06-13T15:32:11+0300] [ALPM] upgraded qemu-tests (9.0.0-1 β†’ 9.0.1-1)
[2024-06-13T15:32:11+0300] [ALPM] upgraded qemu-tools (9.0.0-1 β†’ 9.0.1-1)
[2024-06-13T15:32:11+0300] [ALPM] upgraded qemu-full (9.0.0-1 β†’ 9.0.1-1)
[2024-06-13T18:29:33+0300] [ALPM] upgraded ark (24.05.0-1 β†’ 24.05.1-1)
[2024-06-13T18:29:33+0300] [ALPM] upgraded baloo-widgets (24.05.0-1 β†’ 24.05.1-1)
[2024-06-13T18:29:33+0300] [ALPM] upgraded libkexiv2 (24.05.0-1 β†’ 24.05.1-1)
[2024-06-13T18:29:33+0300] [ALPM] upgraded kio-extras (24.05.0-1 β†’ 24.05.1-1)
[2024-06-13T18:29:33+0300] [ALPM] upgraded dolphin (24.05.0-1 β†’ 24.05.1-1)
[2024-06-13T18:29:33+0300] [ALPM] upgraded dolphin-plugins (24.05.0-1 β†’ 24.05.1-1)
[2024-06-13T18:29:33+0300] [ALPM] upgraded ffmpegthumbs (24.05.0-1 β†’ 24.05.1-1)
[2024-06-13T18:29:33+0300] [ALPM] upgraded libkdcraw (24.05.0-1 β†’ 24.05.1-1)
[2024-06-13T18:29:33+0300] [ALPM] upgraded signon-kwallet-extension (24.05.0-1 β†’ 24.05.1-1)
[2024-06-13T18:29:33+0300] [ALPM] upgraded kaccounts-integration (24.05.0-1 β†’ 24.05.1-1)
[2024-06-13T18:29:33+0300] [ALPM] upgraded gwenview (24.05.0-1 β†’ 24.05.1-1)
[2024-06-13T18:29:33+0300] [ALPM] upgraded kate (24.05.0-1 β†’ 24.05.1-1)
[2024-06-13T18:29:34+0300] [ALPM] upgraded kcalc (24.05.0-2 β†’ 24.05.1-1)
[2024-06-13T18:29:34+0300] [ALPM] upgraded kdeconnect (24.05.0-2 β†’ 24.05.1-1)
[2024-06-13T18:29:34+0300] [ALPM] upgraded kdegraphics-mobipocket (24.05.0-1 β†’ 24.05.1-1)
[2024-06-13T18:29:34+0300] [ALPM] upgraded kdegraphics-thumbnailers (24.05.0-1 β†’ 24.05.1-1)
[2024-06-13T18:29:34+0300] [ALPM] upgraded kdenetwork-filesharing (24.05.0-1 β†’ 24.05.1-1)
[2024-06-13T18:29:34+0300] [ALPM] upgraded kio-admin (24.05.0-1 β†’ 24.05.1-1)
[2024-06-13T18:29:34+0300] [ALPM] upgraded konsole (24.05.0-1 β†’ 24.05.1-1)
[2024-06-13T18:29:34+0300] [ALPM] upgraded okular (24.05.0-1 β†’ 24.05.1-1)
[2024-06-13T18:29:34+0300] [ALPM] upgraded spectacle (24.05.0-1 β†’ 24.05.1-1)
[2024-06-13T21:30:16+0300] [ALPM] upgraded fwupd (1.9.20-1 β†’ 1.9.21-1)
[2024-06-13T21:30:16+0300] [ALPM] upgraded libwacom (2.12.0-1 β†’ 2.12.1-1)
[2024-06-14T10:47:07+0300] [ALPM] upgraded endeavouros-mirrorlist (24.6-1 β†’ 24.6.1-1)
[2024-06-14T10:47:07+0300] [ALPM] upgraded eos-rankmirrors (24.4-1 β†’ 24.6-1)
[2024-06-14T10:47:07+0300] [ALPM] upgraded linux-lts (6.6.32-1 β†’ 6.6.33-1)
[2024-06-14T10:47:09+0300] [ALPM] upgraded linux-lts-headers (6.6.32-1 β†’ 6.6.33-1)
[2024-06-14T22:05:21+0300] [ALPM] upgraded perl-alien-build (2.80-2 β†’ 2.83-1)
[2024-06-14T22:05:22+0300] [ALPM] upgraded python-orjson (3.10.4-1 β†’ 3.10.5-1)
[2024-06-14T22:37:50+0300] [ALPM] upgraded alsa-lib (1.2.11-1 β†’ 1.2.12-1)
[2024-06-14T22:37:50+0300] [ALPM] upgraded alsa-plugins (1: β†’ 1:1.2.12-1)
[2024-06-14T22:37:50+0300] [ALPM] upgraded alsa-utils (1.2.11-1 β†’ 1.2.12-1)
[2024-06-14T22:37:50+0300] [ALPM] upgraded lib32-alsa-lib (1.2.11-1 β†’ 1.2.12-1)
[2024-06-14T22:37:50+0300] [ALPM] upgraded lib32-alsa-plugins ( β†’ 1.2.12-1)
[2024-06-15T19:28:16+0300] [ALPM] upgraded freeglut (3.4.0-1 β†’ 3.6.0-1)
[2024-06-15T19:28:17+0300] [ALPM] upgraded gamescope (3.14.16-1 β†’ 3.14.18-2)
[2024-06-15T19:28:17+0300] [ALPM] upgraded lib32-freeglut (3.4.0-1 β†’ 3.6.0-1)
[2024-06-15T19:28:17+0300] [ALPM] upgraded python-pydantic (2.7.3-1 β†’ 2.7.4-1)
[2024-06-15T19:29:57+0300] [ALPM] upgraded brave-bin (1:1.66.118-1 β†’ 1:1.67.116-1)
[2024-06-16T09:12:56+0300] [ALPM] upgraded wine (9.10-1 β†’ 9.11-1)
[2024-06-16T20:25:57+0300] [ALPM] upgraded libxml2 (2.13.0-1 β†’ 2.13.0-3)
[2024-06-16T20:25:57+0300] [ALPM] upgraded lib32-libxml2 (2.13.0-1 β†’ 2.13.0-3)
[2024-06-16T20:25:58+0300] [ALPM] upgraded rust (1:1.78.0-1 β†’ 1:1.79.0-1)
[2024-06-16T20:25:58+0300] [ALPM] upgraded lib32-rust-libs (1:1.78.0-1 β†’ 1:1.79.0-1)
[2024-06-16T20:25:58+0300] [ALPM] upgraded libimobiledevice-glue (1.2.0-1 β†’ 1.3.0-1)
[2024-06-16T20:25:58+0300] [ALPM] upgraded libxslt (1.1.40-1 β†’ 1.1.40-2)
[2024-06-16T20:25:59+0300] [ALPM] upgraded man-pages (6.8-1 β†’ 6.9-1)
[2024-06-16T20:25:59+0300] [ALPM] upgraded poppler (24.06.0-1 β†’ 24.06.1-1)
[2024-06-16T20:25:59+0300] [ALPM] upgraded poppler-glib (24.06.0-1 β†’ 24.06.1-1)
[2024-06-16T20:25:59+0300] [ALPM] upgraded poppler-qt6 (24.06.0-1 β†’ 24.06.1-1)
[2024-06-16T20:25:59+0300] [ALPM] upgraded pv (1.8.9-1 β†’ 1.8.10-1)
[2024-06-17T17:11:50+0300] [ALPM] upgraded editorconfig-core-c (0.12.8-1 β†’ 0.12.9-1)
[2024-06-17T17:11:50+0300] [ALPM] upgraded exfatprogs (1.2.3-1 β†’ 1.2.4-1)
[2024-06-17T17:11:50+0300] [ALPM] upgraded libnghttp3 (1.3.0-1 β†’ 1.4.0-1)
[2024-06-17T17:11:50+0300] [ALPM] upgraded lib32-libnghttp3 (1.3.0-1 β†’ 1.4.0-1)
[2024-06-17T17:11:50+0300] [ALPM] upgraded linux (6.9.4.arch1-1 β†’ 6.9.5.arch1-1)
[2024-06-17T17:11:52+0300] [ALPM] upgraded linux-headers (6.9.4.arch1-1 β†’ 6.9.5.arch1-1)
[2024-06-17T17:11:53+0300] [ALPM] upgraded linux-zen (6.9.4.zen1-1 β†’ 6.9.5.zen1-1)
[2024-06-17T17:11:55+0300] [ALPM] upgraded linux-zen-headers (6.9.4.zen1-1 β†’ 6.9.5.zen1-1)
[2024-06-17T17:11:55+0300] [ALPM] upgraded multipath-tools (0.9.8-1 β†’ 0.9.9-1)
[2024-06-17T17:11:55+0300] [ALPM] upgraded reflector-simple (2023-4 β†’ 2024-1)
[2024-06-17T17:26:25+0300] [ALPM] upgraded linux-lts (6.6.33-1 β†’ 6.6.34-1)
[2024-06-17T17:26:26+0300] [ALPM] upgraded linux-lts-headers (6.6.33-1 β†’ 6.6.34-1)
[2024-06-17T22:48:26+0300] [ALPM] upgraded talloc (2.4.2-2 β†’ 2.4.2-3)
[2024-06-18T10:48:15+0300] [ALPM] upgraded cmake (3.29.5-2 β†’ 3.29.6-1)
[2024-06-18T10:48:15+0300] [ALPM] upgraded endeavouros-mirrorlist (24.6.1-1 β†’ 24.6.3-1)
[2024-06-18T10:48:15+0300] [ALPM] upgraded eos-rankmirrors (24.6-1 β†’ 24.6.1-1)
[2024-06-18T10:48:15+0300] [ALPM] upgraded lib32-gettext (0.22.4-1 β†’ 0.22.5-1)
[2024-06-18T10:48:15+0300] [ALPM] upgraded lib32-libcups (2.4.8-1 β†’ 2.4.9-1)
[2024-06-18T10:48:15+0300] [ALPM] upgraded perl-html-tagset (3.20-14 β†’ 3.24-1)
[2024-06-18T10:49:42+0300] [ALPM] upgraded minecraft-launcher (1:1.0.1221-1 β†’ 1:1.0.1221-3)
[2024-06-18T15:23:27+0300] [ALPM] upgraded systemd-libs (255.7-1 β†’ 256-3)
[2024-06-18T15:23:27+0300] [ALPM] upgraded cryptsetup (2.7.2-1 β†’ 2.7.3-1)
[2024-06-18T15:23:27+0300] [ALPM] upgraded endeavouros-mirrorlist (24.6.3-1 β†’ 24.6.4-1)
[2024-06-18T15:23:27+0300] [ALPM] upgraded iniparser (4.2.2-1 β†’ 4.2.4-1)
[2024-06-18T15:23:27+0300] [ALPM] upgraded libxml2 (2.13.0-3 β†’ 2.13.0-4)
[2024-06-18T15:23:27+0300] [ALPM] upgraded lib32-libxml2 (2.13.0-3 β†’ 2.13.0-4)
[2024-06-18T15:23:27+0300] [ALPM] upgraded lib32-systemd (255.7-1 β†’ 256-1)
[2024-06-18T15:23:28+0300] [ALPM] upgraded python (3.12.3-1 β†’ 3.12.4-1)
[2024-06-18T15:23:29+0300] [ALPM] upgraded python-jaraco.text (3.12.0-3 β†’ 3.12.1-1)
[2024-06-18T15:23:29+0300] [ALPM] upgraded systemd (255.7-1 β†’ 256-3)
[2024-06-18T15:23:30+0300] [ALPM] upgraded systemd-resolvconf (255.7-1 β†’ 256-3)
[2024-06-18T15:23:30+0300] [ALPM] upgraded systemd-sysvcompat (255.7-1 β†’ 256-3)
[2024-06-19T10:15:11+0300] [ALPM] upgraded cfitsio (1:4.4.0-1 β†’ 1:4.4.1-1)
[2024-06-19T10:15:11+0300] [ALPM] upgraded spirv-tools (2024.1-1 β†’ 2024.2-1)
[2024-06-19T10:15:11+0300] [ALPM] upgraded glslang (14.1.0-1 β†’ 14.2.0-1)
[2024-06-19T10:15:11+0300] [ALPM] upgraded libndp (1.8-1 β†’ 1.8-2)
[2024-06-19T10:15:11+0300] [ALPM] upgraded shaderc (2024.0-1 β†’ 2024.1-1)
[2024-06-19T10:15:11+0300] [ALPM] upgraded libplacebo (6.338.2-6 β†’ 6.338.2-7)
[2024-06-19T10:15:12+0300] [ALPM] upgraded python-fastjsonschema (2.19.1-3 β†’ 2.20.0-1)

The important things I see updated were systemd, cryptesetup, and the kernel. It is probably one of those things. You can try downgrading the kernel to whatever version worked for you last with the downgrade command.

It only started occuring on the 18th after updating and rebooting, how can I downgrade systemd then?

With the downgrade command. Make sure to downgrade all the different systemd stuff though. I see systemd systemd-resolvconf systemd-sysvcompat lib32-systemd systemd-libs. All of those should be downgraded to the same version.

I also found this thread on the arch forumns from about a week ago https://bbs.archlinux.org/viewtopic.php?id=296699

in my PKG folder I only have the newest version files avaliable, but the older version of lib32-systemd is avaliable.

The downgrade command allows you to download previous versions as well as use old ones already on the system. The ones it has to download simply say remote by them.

Nah, I recommend to download all of the components of systemd that I listed to the same version.

I downgraded to the previous version I had and /dev/tpmrm0 seems to properly start now, I appreciate the help.

No problem. My goal was just to get it working. I don’t know what broke it or how it is supposed to be configured. Maybe it will be fixed in a different update or something. For now, I’ll turn things over to someone more knowledgeable about tpm. If they should come along.

1 Like

Doing a β€œshallow” search on your issue, the only reference I found is this Arch Forum’s thread:


where people are getting around this issue by disabling some systemd services.

If this issue is indeed due to a regression in systemd, I would urge you to file a report on systemd’s issue tracker at Github.

Keeping an important component of the system, which the init system indeed is, from being updated is not a viable approach in the long run.

Unless the devs know about it, they couldn’t possibly resolve the issue.

I filed a report on their Github as you urged, hopefully it gets fixed in the next version.

1 Like

Sounds great! That’s the spirit!


Looks like there was bug fix release today. It mentioned a fix for tpm issue. I’m just not sure it is the fix to your issue though.