A not so important KDE Plasma theming question

I know it’s no biggie but it has been bugging me for a while now. In the panel selection there is a purple tint behind the icons when I mouse over, and -sorry for swearing in church - I’m not I very purple guy, and it goes badly with the rest of my theming. I have looked everywhere [most probably not] in settings but I don’t seem to be able to find how to change that.

Anyone who knows how to solve this extremely important issue? :thinking:

1 Like

Start by posting a screenshot

My brain’s iGPU isn’t working right now , can’t imagine :upside_down_face:

1 Like

Here is a “screenphoto” as screenshoot doesn’t work in that menu. :slight_smile:

I’m referring to the purple behind the icon and “senaste program”.

Go into system settings and see if changing the colors option changes that. I am not at my machine to look but you may be able to change just that color.

Yeah, it should be in colors, but i think it’s based on common Selection background or something like that, so you can’t individually change it

1 Like

Now i tried i few different, but it doesn’t matter. It stays purple. :cry:

1 Like

Did you reboot? Or log out and back in after the change?

I did not. BRB.

Settings > Appearance > Colors

Click on edit icon of your color set . Then you will see many options under Colors . One of them will solve this . Give these a try Hover Decoration , Selection Bckground

2 Likes

Reboot shouldn’t be necessary with modern KDE though, at least it wasn’t month ago, they’ve made live-apply

3 Likes

Thanks, that was a feature that was good to know. Unfortunately, it didn’t work for the one thing I really wanted to change.

I now, but I did just in case. :slight_smile:

1 Like

One far fetched thought, as Xfce is themed and Plasma supposedly isn’t, but can this be an exception from that rule?

Oh i forgot to mention that your Plasma style must have Follows color scheme under it’s name to actually follow color changes

Sorry, KDE is a mess of settings :sweat_smile:

4 Likes

Try changing the Plasma theme, some hard code the colors in the SVG files rather than inherit it from the color theme.

2 Likes

…and that did the trick! :dizzy: :boom:

Thanks!

I know. The hours I’ve spent searching the settings when I was new to Plasma… and still does, obviously. :rofl:


…and thanks to klorax too, as he also was right, but I needed that “Follows color scheme”, so solution goes to keybreak.

5 Likes

Have a happy plasma! :partying_face:

6 Likes

I just found out I can customize my Plasma style :grimacing: because of keybreak mentioning it . Thanks @keybreak

2 Likes