A little warning for new users who installed Deepin

Are you a new user and you’ve just installed Deepin? Then you must be aware that Deepin V.20 very recently hit the Arch repo.

This version hasn’t reached maturity completely since the Deepin devs went in another direction with the DE.
The DE is receiving updates regularly but a lot of basic features work partially or not at all. These bugs are usually temporary and will be fixed over time.

We don’t have control over these bugs and we can’t hold the updates back since this is the nature of a rolling release distro.

At this moment we recommend to have Deepin installed next to another DE, as a secondary option.

9 Likes

it is so called beta also, just installed in VM now:

Updating from older installs will also put you in some trouble, as changes are huge on all the apps and the interface itself! so be aware to think about installing a second DE as fallback to it!

2 Likes

Well mine used to look as nice as that, then some more patches arrived and then everything went ugly. Icons for network are tiny, missing icons in the file explorer, and then the menu options are white text on a grey background. Any ideas on how I make a clean deepin configuration? Otherwise I just back up my VM directory and wipe my home directory entirely :wink:

I am not sure there would be a point to that. Here is what it currently looks like on a clean config with the latest updates.

It is just broken after those last few updates. Probably need to wait for the next updates…

1 Like

Thanks, I’ll hold off. Just a shame the last updates sent it backwards in terms of usability

1 Like

It looks like deepin-qt5integration 5.1.0.1-2 fixes the issue.

It should be inbound on most mirrors now.

6 Likes

Can more Deepin users confirm this also? If that’s the case I will unpin this thread.

I haven’t gotten around to trying out Deepin yet, however I appreciate the “head’s up” all the same. I’ll remember that if I decide to try it out at some point on this (my) personal journey back into the wonderful word of near-complete technological freedom.

Yes, fixed that QT issue alone. But I have to qualify that to say that there are other random issues with Deepin’s apps that make it unusable, eg the File manager randomly stops browsing, and needs to be xkilled.

2 Likes

To be clear, I wasn’t saying that the deepin issues were all fixed. Just that the problem above my post with icons and theming was resolved.

There are still other issues. At the end of the day, this is beta software and the warning to treat it as such is probably warranted.

2 Likes

I figured that, thank you for the update.

1 Like

I just tested it today. It’s good to have the warning because it was definitely not ready for use

It was pausing, freezing, and crashing all the time on almost everything I did

Other than that it looks nice but I preferred the unique side panel system settings. I’ll probably give it another shot when the real release is ready

2 Likes

Everything is working great with deepin, no issues so far. If you’re having issues, it is probably because of the packages you’re installing. I’ve just installed endeavour with deepin desktop and noticed all the bugs you’re reporting, but quickly check if I was using deepin-kwin, and that’s it, endeavour as manjaro, installs deepin-mutter by default and it is not compatible with newer versions of deepin. I just installed it and reboot my machine and all the issues were solved.

I think endeavour must change deepin-mutter with deepin-kwin to avoid all these issues.

3 Likes

ComplicatedWildKitten-small

Everything is not working great on Deepin on my hardware on v-box. No matter what i do it freezes up the whole computer, I have tried everything… except installing it on bare metal. Not happy with it. :unamused:

It is all coming from Arch. deepin-kwin was added the packaging today and felixonmars said he was working on removing deepin-mutter from the list of dependencies.

2 Likes

Which video driver are you using with virtualbox?

Which ever one installs with it i guess?

When you click on the vm in virtualbox manager it shows it.

image