404 on endeavouros.db (from github) when updating

I fired up an old computer I don’t use very much and tried to update it - only to get a 404 when it tried to get the endeavouros.db from github. It’s basically the same as this issue, I think?

but the solution given there provides 2 urls which are also 404s.

I’ve tried reflector-simple, and it ran with no errors, but the problem persists.

Some suggestions said to use the welcome tool’s “update mirrors” but that gives the following error:

Error: configuration 'eos-run-cmd-with-su' for EOS_ROOTER in file /etc/eos-script-lib-yad.conf is not supported!

I also saw eos-rankmirrors suggested somewhere, but that errors with a command not found

You may need to update your endeavouros mirrorlist.

You can use the command eos-rankmirrors

Haha, sorry, I hadn’t finished posting all my failures - I’ve tried to update the mirrors a few ways, some successful (reflector-simple) and some not (eos-rankmirrors) - but no luck.

I can see where to put correct db urls, I think - /etc/pacman.d/endeavouros-mirrorlist - but I don’t have correct urls to put there.

You can replace it with this file: https://github.com/endeavouros-team/PKGBUILDS/blob/master/endeavouros-mirrorlist/endeavouros-mirrorlist

1 Like

Ok, that’s weird - that url works in the browser, but I still get a 404 from pacman. Just for kicks, I put the mirrorlist up on my work’s server, and I still get a 404… the other databases download fine (core, extra, etc), but not the eos one…

To be clear, you replaced the file with the file located at that link, correct?

Just making sure you didn’t add that URL to the file.

1 Like

haha, no, I added the url to the file - totally misunderstood that!

A moment ago, I noticed another error, about pgp signatures, and I realized, even if I get this issue sorted, I’m going to have to update those - so I disabled the eos repository in pacman.conf and updated archlinux-keyring and now I’m doing a full pacman -Syyu without eos - it’s 3gb of downloads so it’s taking a while… I’ll change the eos mirrorlist file when the update finishes.

Ok, the eos-less update went fine; I restarted to a still-functional system and I’m going to take that as a win.

However, when I replaced /etc/pacman.d/endeavouros-mirrorlist with the file you linked, and then ran pacman -Syyu I got this:

error: GPGME error: No data
error: failed to synchronize all databases (unexpected error)

A new error! Progress!

ok - solved! per this: https://bbs.archlinux.org/viewtopic.php?id=276095

I moved the /var/lib/pacman/sync/ folder to my ~/ (because who just deletes stuff???) and updated - and - great success! It worked!

ok, so summarize for the benefit of anyone who finds this later:

  1. disabled the eos repository - probably didn’t need to do this, had I done step 3 first:
    a. vim /etc/pacman.conf then added # before the 3 lines that defined the eos repo (around lines 75-77)
  2. updated pgp keys then system update without eos:
    a. pacman -S archlinux-keyring
    b. pacman -Syyu
  3. replaced the url reference to the eos mirrorlist with the actual mirror list:
    a. wget https://github.com/endeavouros-team/PKGBUILDS/blob/master/endeavouros-mirrorlist/endeavouros-mirrorlist
    b. mv /etc/pacman.d/endeavouros-mirrorlist /etc/pacman.d/orig.endeavouros-mirrorlist && mv endeavouros-mirrorlist /etc/pacman.d/
  4. update and celebrate:
    a. pacman -Syyu

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.