Zoom permissions not working

When I join a Zoom video conference meeting, I can’t unmute myself or turn on the video. If I try to unmute myself, I get a message saying that the host is not allowing participants to unmute themselves.
The host allows this, and when I join this same meeting from Ubuntu or from Windows, I have no problem unmuting and enabling video.
I tried removing and reinstalling Zoom from AUR, and I deleted my user config files, but the issue persists.

But Zoom works right on a Wayland session. :upside_down_face:

And no problem with web app of Zoom.

inxi -F
System:
  Host: endeavouros Kernel: 6.6.9-arch1-1 arch: x86_64 bits: 64
    Desktop: KDE Plasma v: 5.27.10 Distro: EndeavourOS
Machine:
  Type: Desktop Mobo: ASUSTeK model: PRIME B365M-A v: Rev X.0x
    serial: <superuser required> UEFI: American Megatrends v: 2208
    date: 07/09/2021
Battery:
  ID-1: hidpp_battery_0 charge: 90% condition: N/A
CPU:
  Info: 8-core model: Intel Core i7-9700 bits: 64 type: MCP cache: L2: 2 MiB
  Speed (MHz): avg: 1287 min/max: 800/4700 cores: 1: 800 2: 800 3: 800
    4: 800 5: 800 6: 4700 7: 800 8: 800
Graphics:
  Device-1: Intel CoffeeLake-S GT2 [UHD Graphics 630] driver: i915 v: kernel
  Device-2: USB C Video Adaptor driver: N/A type: USB
  Device-3: Microdia USB Live camera driver: snd-usb-audio,uvcvideo
    type: USB
  Display: x11 server: X.Org v: 21.1.10 driver: X: loaded: modesetting
    dri: iris gpu: i915 resolution: 1: 1920x1080 2: 1920x1080~60Hz
  API: EGL v: 1.5 drivers: iris,swrast platforms: x11,surfaceless,device
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 23.3.2-arch1.2
    renderer: Mesa Intel UHD Graphics 630 (CFL GT2)
  API: Vulkan Message: No Vulkan data available.
Audio:
  Device-1: Intel 200 Series PCH HD Audio driver: snd_hda_intel
  Device-2: Microdia USB Live camera driver: snd-usb-audio,uvcvideo
    type: USB
  API: ALSA v: k6.6.9-arch1-1 status: kernel-api
  Server-1: PipeWire v: 1.0.0 status: active
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8169
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: a8:5e:45:e2:87:3c
  Device-2: Realtek RTL8153 Gigabit Ethernet Adapter driver: r8152 type: USB
  IF: enp0s20f0u3u1 state: down mac: 00:e0:4c:68:51:92
Bluetooth:
  Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) driver: btusb
    type: USB
  Report: btmgmt ID: hci0 state: up address: 00:1A:7D:DA:71:13 bt-v: 4.0
Drives:
  Local Storage: total: 2.26 TiB used: 804.82 GiB (34.8%)
  ID-1: /dev/sda vendor: Kingston model: SA400S37480G size: 447.13 GiB
  ID-2: /dev/sdb vendor: Toshiba model: HDWD120 size: 1.82 TiB
Partition:
  ID-1: / size: 85.39 GiB used: 14.7 GiB (17.2%) fs: ext4 dev: /dev/sda7
  ID-2: /boot/efi size: 96 MiB used: 50.6 MiB (52.7%) fs: vfat
    dev: /dev/sda1
Swap:
  Alert: No swap data was found.
Sensors:
  System Temperatures: cpu: 34.0 C mobo: N/A
  Fan Speeds (rpm): N/A
Info:
  Processes: 262 Uptime: 2m Memory: total: 16 GiB available: 15.49 GiB
  used: 3.13 GiB (20.2%) Shell: Zsh inxi: 3.3.31

I take back the claim that it works on Wayland, because the issue showed up again even on Wayland. I tried using the binary provided directly by Zoom (not by AUR), but it’s the same problem.
However, the flatpak version seems to work right.
I can’t find this issue reported on the Arch forum or the Zoom forum, so I am pretty puzzled why this bug bit me.

Cannot duplicate in Budgie. I have AUR Zoom as well.
What does the terminal output say when you run zoom?
Have you tried uninstalling AUR Zoom and trying flatpak Zoom? If that fails, too, then we can narrow it down to a system/sound problem. Lot’s of great system/sound troubleshooters at forum (I am not one).
Or
maybe in system settings (depending on DE) you have cam/mic off limits/disabled?
Or maybe a zoom setting overlooked?
If it’s permissions thing then the last two fit the bill.

OK, my brain is officially mostly empty. Will edit if more stuff comes to mind.

When I run it in terminal, it starts without errors. The issue is when I join a meeting.

I know. I was just wondering if there was a tell-tale weird clue in the output that may have something to do with it. low-percentage speculation, I do admit

I deleted some site-specific cookies from my browser – zoom and google accounts – and that seems to have resolved the issue.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.