Zoom crashes on call start

Hi, today I installed Endeavour for the first time. Afterwards, I downloaded Zoom for a call I had to join. I installed it according to their instructions. It launched well, I signed up and tested my mic and camera to be working (in their Settings, without starting any test call as is the case in, e.g., Skype). All seemed to work. However, when I finally joined a real Zoom call, the app immediately crashed. I tried it multiple times but it never worked. I click Join call, the app launches, I select “Join with video” and an empty call window appears and then crashes.

If that is of any use, I am using Sway.

What could be the problem and how could I fix it please?

Hi, welcome to the forum.

I’m not completely sure which method you’ve used, but I have no issues with the zoom version you can find in the AUR.

Just type: yay -S zoom in the terminal and you will be good to go.

1 Like

You may find there are clues to the failure of the application in the following command:

journalctl -xe

or

journalctl -xe | grep zoom

I rely on zoom for teaching and I haven’t had any issues with it.

As Bryan says, install from aur, though I have used the one off their website successfully.

I’d suggest running it from the command line using the command zoom if you need more feedback as to why it crashes.

Thanks for your answers. I have installed the version from AUR. I tried the test call on zoom website. It still sometimes crashes even on this test call.

I am unable to reliably find a pattern in when it crashes and when it doesnt. I am repeatedly trying the test call and sometimes it works as it should even 3-5 times in a row. However, sometimes it crashes. Then it may crash even several times in a row. I have executed journalctl -xe | grep zoom. After one crash the output looks like:

jun 16 13:06:26 mypc audit[2258]: ANOM_ABEND auid=1000 uid=1000 gid=1000 ses=2 pid=2258 comm="QSGRenderThread" exe="/opt/zoom/zoom" sig=11 res=1
jun 16 13:06:26 mypc kernel: audit: type=1701 audit(1623841586.108:108): auid=1000 uid=1000 gid=1000 ses=2 pid=2258 comm="QSGRenderThread" exe="/opt/zoom/zoom" sig=11 res=1
jun 16 13:06:32 mypc systemd-coredump[2944]: Process 2258 (zoom) of user 1000 dumped core.
░░ Subject: Process 2258 (zoom) dumped core
░░ Process 2258 (zoom) crashed and dumped core.

There can be several factors causing this. Firstly, have you tried a different kernel?

Also, read through the AUR page comments for Zoom as there are many fixes included for various issues regarding zoom crashes.

Could it be that wayland is causing issues?
I suggest trying zoom on Xorg based DE/WM. Xfce. Or i3 if you want small and minimal for testing.

That could be the culprit, I run Plasma on Xorg.

1 Like

No, I have not tried using a different kernel. Could you recommend any version for me to use?

I have not found a similar isuee on the AUR comments page. However, I found one commenter saying he got it running on Wayland with no issues. I will try to run it on i3 and see how it behaves.

1 Like

I don’t use zoom on linux myself, but the most obvious choice to me would be to try the LTS kernel. You can install it with akm through the welcome screen and then boot into it when given the option at start up.

You could try the zen kernel just to see if it will work, but now realizing you are on Wayland, that might be the issue, as other’s have suggested above. Keep us posted. thx.

1 Like

I have tried both lts and zen but Zoom was still failing. I have reinstalled Endeavour to use i3 instead of Sway and now Zoom seems to work well.

3 Likes

So, it is most likely a Wayland issue, which is understandable. Great you’ve figured it out.

1 Like

2021-06-21_18-39
I remember the question from chat … it is only working with wayland and GNOME.

But it works with Anter Gos :wink:

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.