Zoom cannot screenshare (wayland)

Hello, since a while I cannot use Zoom to screenshare on Wayland anymore.

Can not start share, we only support Wayland on GNOME with Ubuntu 17 and above, Fedora 25 and above, Debian 9 and above, If your OS in not on the list, please use x11 instead

Any ideas?

Same issues on Plasma+Wayland. But given the generally unstable zoom client for linux, I run plasma/x11 when zoom in browser is required.

Yes, they have updated the utilized Gnome-API for Wayland which only works on their ‘supported’ OS. The old trick where you added enableWaylandScreenshare=true to the config does no longer work (although I don’t use Gnome, so it might work on Gnome regardless of the used OS).

I highly recommend using Zoom in your browser as this uses the appropriate WebRTC API for screensharing and works perfectly fine on Wayland, regardless of you DE/WM/OS.

Hi there!

TL;DR: The issue has apparently been submitted to the Zoom developers.

I’ve hit the same issue with Zoom for desktop. I must admit that I haven’t tried Zoom in my browser, since I just read about this work-around now, but I might try it out tomorrow.

Regardless, I think the desktop app should be fixed. Because I’m pretty sure there isn’t a problem with EOS since Arch is supported. (And shouldn’t they do a real check on library dependencies and their versions rather than some error-prone OS whitelist? Was this implemented by children or what?)

I contacted Zoom support and raised the issue. They told me that they won’t allow me to submit this, but that I should have my company zoom administrator do this for me. And by the way, what a polite way to tell me to fsck off. Or perhaps filtering the amount of incoming traffic for the development team. But for all I know, my admin doesn’t use zoom himself, he certainly doesn’t use EOS, and I’m pretty sure he doesn’t really care about my problem. So I wrestled with a couple of supporters for a few days, basically explaining them that their setup wasn’t working for me, and asked them to escalate matters to someone who could in fact help me. And apparently they did something. Because now my Company Success Manager (!) was pulled into the loop and says he has submitted the feature on my behalf. Snippet of the last mail I received included below:

Nice to e-meet you! My name’s [his name], your assigned CSM for [the company where I work]. I have submitted the feature request on your behalf to have the ability of screen sharing in Endavour Linux. Please be advised that the request will be evaluated and possibly implemented in a future release. This said, we cannot guarantee any defined release date for the feature release. I will keep you posted should there be any news on this moving forward.

There you have it. I hope he brings success, not only to my company (well, me), but to everyone who uses EOS =). I’ll keep you update, though I won’t expect any news in the near future.

Have a nice day.