Zerotier, I can join games but when i host games people can't connect

I have been playing some LAN games with my friends using ZeroTier, and it’s working fine, with the only issue being that when I host games, they can’t connect. The games always use my LAN IP instead of the ZeroTier-assigned IP, and when I change the ip on dedicated servers to use the ZeroTier IP, they still can’t connect.

At first, I thought it was the firewall, but I already tried it with the firewall disabled, and I even uninstalled it just to make sure. I did a simple ping test, and they can ping me, and I can ping them. The issue really seems to be that the games don’t use ZeroTier.

The games i tried so far are counter strike, no more room on hell and minecraft.

And as for why i am posting here and not in the zerotier forum, is because they won’t answer, i saw similar posts, they don’t have much support on linux, so its up to “me” fix it “alone”.

Here some network info:

ip addr show

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host noprefixroute 
       valid_lft forever preferred_lft forever
2: eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether a8:5e:45:1e:35:51 brd ff:ff:ff:ff:ff:ff
    altname enp0s31f6
    inet 192.168.15.6/24 brd 192.168.15.255 scope global dynamic noprefixroute eno1
       valid_lft 137218sec preferred_lft 137218sec
    inet6 2804:7f0:2801:d93a:18fe:ce4a:8fc7:2458/64 scope global dynamic noprefixroute 
       valid_lft 42863sec preferred_lft 42863sec
    inet6 fe80::c553:4990:b9d1:31db/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
3: virbr0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default qlen 1000
    link/ether 52:54:00:a5:fa:14 brd ff:ff:ff:ff:ff:ff
    inet 192.168.122.1/24 brd 192.168.122.255 scope global virbr0
       valid_lft forever preferred_lft forever
4: ztrfyjazxu: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 2800 qdisc fq_codel state UNKNOWN group default qlen 1000
    link/ether 7e:af:b5:5c:54:f2 brd ff:ff:ff:ff:ff:ff
    inet 172.29.81.55/16 brd 172.29.255.255 scope global ztrfyjazxu
       valid_lft forever preferred_lft forever
    inet6 fe80::7caf:b5ff:fe5c:54f2/64 scope link proto kernel_ll 
       valid_lft forever preferred_lft forever

nmcli connection show

NAME               UUID                                  TYPE      DEVICE     
Conexão cabeada 1  f93fc5f4-cfb2-365e-8c33-c226a8da691b  ethernet  eno1       
lo                 2ad2057c-f3ef-4496-a447-d98555cb0445  loopback  lo         
ztrfyjazxu         407c3856-66f0-4583-8f18-ad84b1b7783c  tun       ztrfyjazxu 
virbr0             765cc19a-29ff-4a44-aca9-45adbc22ab57  bridge    virbr0

Had to look up what ZeroTier is and saw this on their website

ZeroTier automatically handles the complexities of networking across physical network boundaries, freeing you to spend your time on things that matter most.

Had to laugh, guess your post shows they failed. I have no idea why but if I had to guess firewall rule blocking whatever port it is for those to join your games. Do you know what ports are used for said games?

1 Like

Usually games use 27xxx ports, on ufw i added a rule to allow those ports but nothing changed. Even without any firewall it doesn’t connect. If its firewall it may be my router firewall, which would be weird since i can receive pings.

You may have to port forward from your router to you machine