YouTube videos keep freezing while audio continues in Firefox/Brave

I recently installed EOS with i3, and then added Qtile which is what I’ve been using daily since. I’ve been using Linux on this PC for about five years. First Mint with Cinnamon and then Manjaro with KDE. Everything has been working fine.

The problem is that YouTube videos keep freezing randomly. The video freezes while the audio keeps playing. Sometimes the video freezes for a few seconds before it continues. Other times it freezes for longer and I can use left/right arrow buttons to jump back/forward to make the video play normal again. I’ve also been able to watch 30-45 minute long videos without issues.

My main browser is Firefox, but I also tried installing Brave to see if that helped. It didn’t. I’ve tried playing several videos on Vimeo and I didn’t have any issues, which I found weird.
VLC plays videos without problems.

I enabled HW acceleration in Firefox but that didn’t help.

I’ve tried both the LTS and 6.4.1-arch2-1 kernel.

Since this is a more “bare bones” install than I’ve previously used in terms of desktop environments, I’m thinking maybe there are some things I haven’t configured correctly.

Output from inxi -Fxz:

  Kernel: 6.4.1-arch2-1 arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
    Desktop: Qtile v: 0.22.1 Distro: EndeavourOS base: Arch Linux
  Type: Desktop Mobo: ASUSTeK model: PRIME Z370-P v: Rev X.0x
    serial: <superuser required> UEFI: American Megatrends v: 0417
    date: 10/20/2017
  Info: 6-core model: Intel Core i5-8400 bits: 64 type: MCP arch: Coffee Lake
    rev: A cache: L1: 384 KiB L2: 1.5 MiB L3: 9 MiB
  Speed (MHz): avg: 1466 high: 2800 min/max: 800/4000 cores: 1: 2800 2: 800
    3: 800 4: 800 5: 800 6: 2800 bogomips: 33613
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: NVIDIA GP104 [GeForce GTX 1070] vendor: ASUSTeK driver: nvidia
    v: 535.54.03 arch: Pascal bus-ID: 01:00.0
  Display: x11 server: X.Org v: 21.1.8 driver: X: loaded: nvidia
    gpu: nvidia,nvidia-nvswitch resolution: 1: 1920x1200~60Hz 2: 1920x1200~60Hz
    3: 1280x720~60Hz 4: 3840x2160~60Hz
  API: OpenGL v: 4.6.0 NVIDIA 535.54.03 renderer: NVIDIA GeForce GTX
    1070/PCIe/SSE2 direct-render: Yes
  Device-1: Intel 200 Series PCH HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel bus-ID: 00:1f.3
  Device-2: NVIDIA GP104 High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel bus-ID: 01:00.1
  API: ALSA v: k6.4.1-arch2-1 status: kernel-api
  Server-1: PipeWire v: 0.3.72 status: active
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK PRIME B450M-A driver: r8168 v: 8.051.02-NAPI port: d000
    bus-ID: 04:00.0
  IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-1: ASUSTek 2045 Bluetooth 2.0 Device with trace filter driver: btusb
    v: 0.8 type: USB bus-ID: 1-11:4
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
  Local Storage: total: 1.36 TiB used: 567.34 GiB (40.6%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO 1TB size: 931.51 GiB
    temp: 37.9 C
  ID-2: /dev/sda vendor: Samsung model: SSD 840 EVO 250GB size: 232.89 GiB
  ID-3: /dev/sdb vendor: Samsung model: SSD 860 EVO 250GB size: 232.89 GiB
  ID-1: / size: 40.95 GiB used: 13.66 GiB (33.4%) fs: ext4 dev: /dev/sdb3
  ID-2: /boot/efi size: 96 MiB used: 25.5 MiB (26.6%) fs: vfat
    dev: /dev/sda2
  ID-3: /home size: 186.43 GiB used: 90.45 GiB (48.5%) fs: ext4
    dev: /dev/sdb4
  Alert: No swap data was found.
  System Temperatures: cpu: 41.0 C mobo: N/A gpu: nvidia temp: 55 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 28%
  Processes: 186 Uptime: 33m Memory: available: 15.56 GiB
  used: 1.74 GiB (11.2%) Init: systemd Compilers: gcc: 13.1.1 Packages: 1043
  Shell: Bash v: 5.1.16 inxi: 3.3.27

I quickly scanned this post and have come up with the best solution:

Use FreeTube on desktop and NewPipe on mobile.

Never actually use YouTube.

Yes, I didn’t actually read your post, but unless you are having video posting issues, my solution is usually the right answer. :sweat_smile:

1 Like

Have you rebooted the machine after installing the latest kernel also, there has been a Firefox update you can try.

Both the kernel version you described and the new firefox update resolved this issue on my side.

Look at the last posts in this thread:

Start reading posts AND the forum before you give random advice.


Yes, I have rebooted after the update. Thanks for the suggestions.

1 Like

just check if you have xdg-desktop-portal-gnome installed, if so remove it and reboot again.

It’s not installed.

Hmm, then I’m out of options, besides a possible Nvidia issue. I don’t have any Nvidia hardware over here, so perhaps someone else can chime in.

Are you using an ad blocker?

I’m not thinking this is a video driver issue as you state other apps play videos fine. Do you get the same behavior using Odysee or another video service?

That’s something I overlooked, this could be it. Both browsers mentioned have one baked in, more or less.

Youtube has gone very anti ad blocker as they are loosing revenue. So they have gotten worse over the last couple of weeks, to my understanding.

1 Like

Are you using an ad blocker?
I’m not thinking this is a video driver issue as you state other apps play videos fine. Do you get the same behavior using Odysee or another video service?

Yes, I’m using uBlock Origin. I tried disabling it, but the video still freezes.
Videos on Odysse and Vimeo seem to work just fine.

I also tried booting from the EOS iso and adding uBlock Origin to Firefox. I had no issues with YouTube when I tried that.

But I have spent too much time on this already, so I will try more at a later date. It’s more of an annoyance than a real problem anyway. Thanks for trying to help.

Have you had a look at the arch wiki I setup hardware acceleration with my 3080 and everything seems to be working fine. I haven’t had any freezes.

It turns out it was the specific fork of Picom I was using that caused this problem. The fork picom-jonaburg-git to be precise. It recently appeared as “orphaned” when doing system updates, so I replaced it with picom-git, and everything is working as normal.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.