Yay exit status 128

As already pointed out here, when I try to install a package, or update yay/AUR, I get the exit status 128.

The following error translated means; invalid branch name


Also, not sure if the pacman category would fit, since it’s AUR/yay related, and not pacman.



|First Submitted: |2021-06-29 20:43 (UTC)|

|Last Updated: |2021-09-15 21:13 (UTC)|

This one looks pretty outdated and it looks it is cloning into the “wrong” branch:


You might want to remove it and install:



1 Like

First you shouldn’t be using yay -Syyu
To update just use yay otherwise use sudo pacman -Syu. The error message is saying invalid branch.

What is the output

sudo pacman -Syu

Forgot to put the message here, but it’s not only fetchord.

I tried it with Cider, which doesn’t seem to work either, but the Minecraft launcher seems to work, so it is package related…
My bad. :upside_down_face:

I had no problem building and installing fetchcord with yay

What’s in your ~/.gitconfig ?

	email = 50217071+Ilovemyhous@users.noreply.github.com
	name = Ilovemyhous
	defaultBranch = ""

I don’t think it can be left empty.
Either choose a name there (f.e. master or main), or remove that setting completely…


but that’s only the default for init a new repo …

When you git clone it effectively runs git init first and then adds the remote and pulls…

So if there’s config crap that init does not like, it’ll fail.

yes i see tried with an empty one and i got issue to clone inside yay :wink:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.