Yay error with any package


today i decided to move from xfce to kde after a few months with xfce. so i downloaded the new iso from the website and i installed kde without any problems until i tried to install different stuff with yay in the terminal.

pic of the error https://i.imgur.com/LfYbQzn.jpg
this error happening with any package install that i try to do.

so, i’m not a linux pro or even a little good with it so i did the only thing i know without breaking my head, i did a new install with gnome and the same error in any package, so i tried a different distro with arcolinux and the same error.

my question is If this happens to other people? right now? because the only logical things is that it’s a problem with yay. i did try to change the countries in the mirror update in the welcome windows of endeavour and nothing works.

it’s my first time on the forum so sorry if this post is in the wrong place

Did you try installing with

sudo pacman -Syu psensor


yes, it work but not everything i need exist in pacman from what i saw for example when i tried to search for green with envy with this pacman -Ss gwe the package is not there and i need that for oc for gaming.

If you need packages from AUR, you could use paru instead of yay and see if it works better than yay momentarily.

how do i install paru? i’m not that good with linux and yay worked for the few months with xfce so i did not use anything else

sudo pacman -S --needed base-devel
git clone https://aur.archlinux.org/paru.git
cd paru
makepkg -si


PKG-Info on AUR.

Not sure if it even exists in the EnOS repos as pacman-package like yay.



Or: sudo pacman -Syu paru



work ok on my :thinking:

shjimtest@Gnome ~> yay -S psensor
Sync Explicit (1): psensor-1.2.1-4
[sudo] password for shjimtest: 
resolving dependencies...
looking for conflicting packages...

Package (3)         New Version  Net Change  Download Size

core/libmicrohttpd  0.9.76-1       0.45 MiB       0.23 MiB
extra/libxnvctrl    530.41.03-1    0.45 MiB       0.07 MiB
community/psensor   1.2.1-4        1.52 MiB       0.31 MiB

Total Download Size:   0.62 MiB
Total Installed Size:  2.41 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages...
 libxnvctrl-530.4...    76.3 KiB   509 KiB/s 00:00 [----------------------] 100%
 libmicrohttpd-0....   235.6 KiB  1178 KiB/s 00:00 [----------------------] 100%
 psensor-1.2.1-4-...   320.3 KiB  1456 KiB/s 00:00 [----------------------] 100%
 Total (3/3)           632.2 KiB  2.57 MiB/s 00:00 [----------------------] 100%
(3/3) checking keys in keyring                     [----------------------] 100%
(3/3) checking package integrity                   [----------------------] 100%
(3/3) loading package files                        [----------------------] 100%
(3/3) checking for file conflicts                  [----------------------] 100%
:: Processing package changes...
(1/3) installing libmicrohttpd                     [----------------------] 100%
(2/3) installing libxnvctrl                        [----------------------] 100%
(3/3) installing psensor                           [----------------------] 100%
:: Running post-transaction hooks...
(1/5) Arming ConditionNeedsUpdate...
(2/5) Compiling GSettings XML schema files...
(3/5) Updating icon theme caches...
(4/5) Updating the info directory file...
(5/5) Updating the desktop file MIME type cache...
shjimtest@Gnome ~> 

EDit your image show " yay -s psensor"

thank you, paru work

1 Like

not for me for some reason

yes, i use -s to search for the package and then i select the number, it always work until now

yay -Ss

They know, see OP… :wink:

no comment :wink:

1 Like

man yay :wink:
yay -Ss foo
Searches for package foo on the repos or the AUR.

1 Like

I searched through the yay issues on Github (open and closed), but couldn’t find a similar one. So it’d be interesting to know, what causes the issue on your machine.

zero problem on my !! you ever see me post . but if want make bigger I game :wink:

Oops, my bad, I was meaning to answer to @neah , the OP. :v:


1 Like

An AUR package. . . built w/o an AUR helper?!?!

I still think we shouldn’t even ship yay. . . everyone should have to build at least one.

Yeah, I was pretty surprised the other day, finding out this ‘little secret’ by accident… :wink:

Now that even paru (next to yay) is delivered by EnOS as a simple (pacman-installable) repo-package, I start wondering, what else may there be? :rofl:

Certainly, this must have been done for ease-of-use, in case yay for example one day breaks (again)…?

1 Like