Yay error (dependency problem)

while upgrading the systemwith yay -Syu i get the following error


jellyfin-server needs dotnet-runtime that is less than version 7.0.0, but the dotnet-runtime in the official community repo is 7.0.0.sdk100-1. If you update, your dotnet-runtime will be updated to version 7.0.0, which will break the dependency. That’s why the error was issued.


You probably need to install dotnet-runtime-6.0 as well.

so will it be ok if I only install dotnet-runtime-6.0-bin.
I thought it will create dependency problem if I install dependencies manually.

yay -Syu dotnet-runtime-6.0-bin

or should I just uninstall jellyfin-server package and install jellyfin-server-bin . And another thing I tried to uninstall jellyfin-server with yay -Rnsu jellyfin-server but it gave this error https://0x0.st/o6nH.txt

Yes. You have to install jellyfin-server-bin.

thanks fixed it by removing jellyfin(realized jellyfin-server was a dependency of jellyfin package) with yay -Rnsu jellyfin and installing yay -S jellyfin-bin

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.