Yay doesn't upgrade AUR -- "not a git repository"

I have a small server running which doesn’t see much changes, mainly updates.

Lately, yay refuses to update anything from the AUR with the following error:

emk2203@nuc10i3fnk:~$ LANG=C eos-update --yay
eos-update: package updater with additional features
Updating native and AUR apps...
:: Synchronizing package databases...
 endeavouros is up to date
 core is up to date
 extra is up to date
 multilib is up to date
:: Starting full system upgrade...
 there is nothing to do
:: Searching AUR for updates...
:: 1 package to upgrade/install.
1  aur/invidtui-bin  0.4.2-1 -> 0.4.4-1
==> Packages to exclude: (eg: "1 2 3", "1-3", "^4" or repo name)
 -> Excluding packages may cause partial upgrades and break systems
AUR Explicit (1): invidtui-bin-0.4.4-1
:: (0/1) Failed to download PKGBUILD: invidtui-bin
 -> error fetching invidtui-bin: fatal: not a git repository (or any parent up to mount point /)
Stopping at filesystem boundary (GIT_DISCOVERY_ACROSS_FILESYSTEM not set). 
         context: exit status 128

The package is just an example, everything from the AUR gets the same error.

I don’t remember changing anything, except for the frequent updates. I didn’t find anything worthwhile in /etc/makepkg.conf or /etc/pacman.conf either.

Can someone help me here?

I know I can manually build the package as a stopgap measure, but doing it manually every time something from the AUR gets updated gets old quick.

Have you tried cleanbuilding it?

How would I do this? When I use yay, I only get asked if I want to exclude packages. The error happens directly afterwards.

I can build and install it with makepkg. But I want yay to work again.

Pass the --cleanmenu flag

Does downloading the package build files with yay work?

cd /tmp
yay -Ga invidtui-bin

@anthony93 : --cleanmenu doesn’t work. Still the same error.

@manuel : This works. I get the PKGBUILD in a invidtui-bin directory.

Maybe your older install of that package is somehow preventing the update.
If so, you can remove the contents of ~/.cache/yay folder and update again.


Yup, this did the trick. I surgically removed only ~/.cache/yay/invidtui-bin. Update went through without issues.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.