Xrandr limited refresh rate options on laptop i3wm

I have been trying to get my x server to run at 2560x1600@165Hz on my laptop but no matter what i do i can’t get the refresh rate options to show up in xrandr.


After a lot of searching online I manged to get my nvidia settings to show x server info yet that didn’t help with anything as I still can’t change to my desired settings.
I’ve tried reinstalling the drivers, using nvidia-xconfig(which just gave me a black screen after properly moving the config file under xorg.conf.d/20-nvidia.conf), blacklisting nouveau yet none of the solutions I found online changed anything. If anything, it feels like I just bloated my system with a bunch of config files and installs for no reason. I am really new to linux and I’ve been trying for hours to get this to work.

Have you tried adding your resolution to xrandr with –addmode? If it’s not working what’s the output of that?

Thanks a lot for the tip, I’ve managed to produce this output yet I get a black screen whenever i try to switch to the new mode(and 164.97Hz isn’t quite 165 but I can live with that). I can’t enter the tty when it happens and a force reboot just removes the new mode and switches me back to the default one.

Screen 0: minimum 320 x 200, current 2560 x 1600, maximum 16384 x 16384
eDP-1 connected primary 2560x1600+0+0 (normal left inverted right x axis y axis) 344mm x 215mm
   2560x1600     60.00*+
   1920x1200     60.00  
   1920x1080     60.00  
   1600x1200     60.00  
   1680x1050     60.00  
   1280x1024     60.00  
   1440x900      60.00  
   1280x800      60.00  
   1280x720      60.00  
   1024x768      60.00  
   800x600       60.00  
   640x480       60.00  
   2560x1600R   164.97 

Well just to be sure are you certain that your cable/connection/multi monitor setup, etc. support your desired resolution and refresh rate?

I’m on a Lenovo Legion 5 Pro laptop, so yeah I’m sure it does. It might be that the amd integrated gpu is used as primary, although I’m not sure. Here is my --listproviders output:

[rares@rares-endeavouros ~]$ xrandr --listproviders
Providers: number : 1
Provider 0: id: 0x53 cap: 0xf, Source Output, Sink Output, Source Offload, Sink Offload crtcs: 4 outputs: 1 associated providers: 0 name:Unknown AMD Radeon GPU @ pci:0000:05:00.0

Found the answer here:

To set mode on startup create “10-monitor.conf” in xorg.conf.d/ and (assuming you have the same laptop and the modeline is the same) append this to it:

Section "Monitor"
    Identifier "eDP-1"
    Modeline "2560x1600_165" 777.340 2560 2608 2640 2720 1600 1603 1609 1732 -hsync -vsync
    Option "PreferredMode" "2560x1600_165"
EndSection

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.