Xorg-server and xorg-server-common updated to 21.1.13-1 and Gnome gets to login screen and suspends laptop


I did an update (paru) and two of the packages following packages updated:

❯ paru
no new news
[sudo] password for :
:: Synchronizing package databases...
 endeavouros is up to date
 core                            127.5 KiB   494 KiB/s 00:00 [--------------------------------] 100%
 extra                             8.1 MiB  5.36 MiB/s 00:02 [--------------------------------] 100%
 multilib                        138.7 KiB   467 KiB/s 00:00 [--------------------------------] 100%
:: Looking for PKGBUILD upgrades...
:: Looking for AUR upgrades...
:: Looking for devel upgrades...
2 extra/xorg-server         21.1.12-1   -> 21.1.13-1
1 extra/xorg-server-common  21.1.12-1   -> 21.1.13-1

I rebooted my gnome 46 install and when I got to the login screen:

  • The laptop external display shuts off.
  • The laptop will go into suspend.
  • The laptop can wakeup.
  • The first time I woke up the laptop I noticed the login preferences changed from Wayland to Xorg.

OS: EndeavourOS x86_64
ThinkPad T450)
Kernel: 6.8.5-zen1-1-zen
Shell: zsh 5.9
Display (HP E243i): 1920x1200 @ 60Hz
DE: Gnome 46.0
WM: Mutter (Wayland)

The fix, I ended up using downgrade to roll back both the xorg-server and xorg-server-common packages and everything is working.

I cannot find a related bug at:

Have you tried other kernels and saw the same problem occur?
Try the arch kernel via

pacman -S linux linux-headers

Or the LTS kernel:

pacman -S linux-lts linux-lts-headers

I run both the LTS and the ZEN kernels. But to be honest I did not switch to the LTS to see if it is reproducible there. I did do a cold boot after I saw the odd behavior to make sure it was not a one off.

Also note when I updated yesterday … there was no kernel change. Thats why I rolled back xorg-server.

Additionally I don’t think we should ask users to just change kernels when a systems suspends (unless you have a bug suggesting a connection).

The reason I PSA is to make people aware if they hit something similar if they update this week.

Decided to run my updates today and let the xorg-server-common and xorg-server packages updatel and now it is working properly. Both the LTS and Zen kernels updated too. So definitely something was not playing nice.

Only update on weekends if there is a critical CVE fix.