Xorg runs Lightdm at 100% CPU

So, I am now one of those who has lightdm issues. It runs between 98 and 101% CPU load at all times.

Lightdm log:

[+0.00s] DEBUG: Logging to /var/log/lightdm/lightdm.log
[+0.00s] DEBUG: Starting Light Display Manager 1.30.0, UID=0 PID=515
[+0.00s] DEBUG: Loading configuration dirs from /usr/share/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration dirs from /usr/local/share/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration dirs from /etc/xdg/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration from /etc/lightdm/lightdm.conf
[+0.00s] DEBUG: Registered seat module local
[+0.00s] DEBUG: Registered seat module xremote
[+0.00s] DEBUG: Using D-Bus name org.freedesktop.DisplayManager
[+0.00s] DEBUG: _g_io_module_get_default: Found default implementation local (GLocalVfs) for ‘gio-vfs’
[+0.80s] DEBUG: Monitoring logind for seats
[+0.80s] DEBUG: New seat added from logind: seat0
[+0.80s] DEBUG: Seat seat0: Loading properties from config section Seat:*
[+0.80s] DEBUG: Seat seat0: Starting
[+0.80s] DEBUG: Seat seat0: Creating greeter session
[+0.81s] DEBUG: Seat seat0: Creating display server of type x
[+0.81s] DEBUG: posix_spawn avoided (fd close requested)
[+0.81s] DEBUG: Could not run plymouth --ping: Failed to execute child process “plymouth” (No such file or directory)
[+0.81s] DEBUG: Using VT 7
[+0.81s] DEBUG: Seat seat0: Starting local X display on VT 7
[+0.81s] DEBUG: XServer 0: Logging to /var/log/lightdm/x-0.log

xorg.0.log shows now errors.

EDIT: Ah. Lightdm-greeter has a problem?

** (lightdm-gtk-greeter:565): WARNING **: 18:51:13.075: [PIDs] Failed to execute command: /usr/lib/at-spi2-core/at-spi-bus-launcher

** (lightdm-gtk-greeter:565): WARNING **: 18:51:13.076: [PIDs] Failed to execute command: upstart

(lightdm-gtk-greeter:565): Gtk-WARNING **: 18:51:13.360: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node menubar owner GreeterMenuBar)

(lightdm-gtk-greeter:565): Gtk-WARNING **: 18:51:13.375: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node menubar owner GreeterMenuBar)

(lightdm-gtk-greeter:565): Gtk-WARNING **: 18:51:13.400: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node menubar owner GreeterMenuBar)

(lightdm-gtk-greeter:565): Gtk-WARNING **: 18:51:13.426: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node menubar owner GreeterMenuBar)

(lightdm-gtk-greeter:565): Gtk-WARNING **: 18:51:13.444: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node menubar owner GreeterMenuBar)

(lightdm-gtk-greeter:565): Gtk-WARNING **: 18:51:13.461: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node menubar owner GreeterMenuBar)

(lightdm-gtk-greeter:565): Gtk-WARNING **: 18:51:13.477: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node menubar owner GreeterMenuBar)

(lightdm-gtk-greeter:565): Gtk-WARNING **: 18:51:13.494: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node menubar owner GreeterMenuBar)

(lightdm-gtk-greeter:565): Gtk-WARNING **: 18:51:13.511: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node menubar owner GreeterMenuBar)

(lightdm-gtk-greeter:565): Gtk-WARNING **: 18:51:13.528: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node menubar owner GreeterMenuBar)

(lightdm-gtk-greeter:565): Gtk-WARNING **: 18:51:13.543: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node menubar owner GreeterMenuBar)

(lightdm-gtk-greeter:565): Gtk-WARNING **: 18:51:13.561: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node menubar owner GreeterMenuBar)

(lightdm-gtk-greeter:565): Gtk-WARNING **: 18:51:13.659: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node menubar owner GreeterMenuBar)

(lightdm-gtk-greeter:565): Gtk-WARNING **: 18:51:13.679: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node menubar owner GreeterMenuBar)

(lightdm-gtk-greeter:565): Gtk-WARNING **: 18:51:13.698: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node menubar owner GreeterMenuBar)

(lightdm-gtk-greeter:565): Gtk-WARNING **: 18:51:13.717: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node menubar owner GreeterMenuBar)

(lightdm-gtk-greeter:565): Gtk-WARNING **: 18:51:13.735: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node menubar owner GreeterMenuBar)

(lightdm-gtk-greeter:565): Gtk-WARNING **: 18:51:13.754: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node menubar owner GreeterMenuBar)

(lightdm-gtk-greeter:565): Gtk-WARNING **: 18:51:13.772: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node menubar owner GreeterMenuBar)

(lightdm-gtk-greeter:565): Gtk-WARNING **: 18:51:13.791: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node menubar owner GreeterMenuBar)

(lightdm-gtk-greeter:565): Gtk-WARNING **: 18:51:13.810: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node menubar owner GreeterMenuBar)

(lightdm-gtk-greeter:565): Gtk-WARNING **: 18:51:13.829: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node menubar owner GreeterMenuBar)


Edit: x-0.log has “non fatal” problems:

Current version of pixman: 0.40.0
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon May 18 18:51:11 2020
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Internal error:   Could not resolve keysym XF86FullScreen
Errors from xkbcomp are not fatal to the X server
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Internal error:   Could not resolve keysym XF86FullScreen
Errors from xkbcomp are not fatal to the X server

https://bugs.archlinux.org/task/61249

Same logs are there from last year (research) but no one responding :wink:

must be a hickup… i would try reinstalling lightdm

It was just an update, didn’t fix it. I’ll try removing it and putting it back.

reinstall accountsservice too

Nope. Didn’t help.
It starts at 76% and within 10 seconds are up to 97 + %.

GOT IT.
Unfortunately it was the themes I used!!

1 Like

You might want to go into a little more detail here in case someone comes across the same issue :grinning: all I was able to find was some obscure post about gnome and a theme causing light dm issues.

1 Like

Turns out if I searched for the whole line it was not lightdm, it was xorg (going to edit title)
And I found this:
https://forum.sparkylinux.org/index.php?topic=4195.0

In their case it was solved by selecting any other theme than “sparky5”. In my case I picked any theme that wasn’t one of the “adapta” variants I installed Saturday.

2 Likes