Xorg randomly crashing to login screen

Endeavour fam, I need help please! I’ve had this issue for too long and I’m at a loss.

For some reason, Xorg is crashing at random times. When this happens it kicks me to the login screen. The logs always show the same thing. I’ve tried searching log entries and keywords numerous times to no avail.

Systemd log: https://0x0.st/okZe.txt
Xorg log: https://0x0.st/okZ9.txt

System: https://0x0.st/okZu.txt
Peripherals: https://0x0.st/okZp.txt

It just started happening one day after a standard system update several months ago. Sometimes it can be days or weeks without crashing, and other times it will crash 3 times in one day.

Should I submit a bug report to Xorg?

Do the logs indicate an issue with libinput?

Is there a way I can gather more info about the cause of these crashes on my system?

If anyone has any tips or advice on where to go from here, it would be greatly appreciated :pray:

As per

    Stack trace of thread 7805:
    #0  0x000056269ce737a4 miPointerSetPosition (Xorg + 0x587a4)
    [ ... ]

I believe this might be this one? https://gitlab.freedesktop.org/xorg/xserver/-/issues/1260

A fix has been merged 9 months ago; https://gitlab.freedesktop.org/xorg/xserver/-/commit/dc7cb45482cea6ccec22d117ca0b489500b4d0a0. I’m fairly new (again) to the Arch side and do not know how to quickly check if that’s already in what you are running.

Welcome to the forum! :smile:

Have you tried other kernels, like the default or LTS?

Oh snap, that must be it! I use Easystroke to hack per-app scroll speed across my system.

I’m running everything up to date, so I would imagine my Xorg includes that commit. Perhaps there’s been a regression, or the fix doesn’t apply to scroll wheel tick events.

In any case, thank you for finding this issue. You’re a legend. I’m going to head over there and see if anyone’s interested in looking deeper into this :eyes:

Thank you!

Yes I have, no change unfortunately.

Well, I’m actually skeptical: the X server is more or less abandonware at this point and I’d be surprised if upstream release pace has picked up enough for even Arch to have that already. But, yeah, sorry for not being certain or knowing how to make certain (well, other than downloading the Arch package sources and looking…)

Well, you’re right to be skeptical. I just checked and it’s not included in the latest release from July :see_no_evil:

I think this is the first time I’m actually getting the itch to migrate to Wayland. I’m sure it will only be a few more years before KDE is ready…

Hey, if you think you have it bad, I’m on XFCE and Cinnamon…

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.