Xorg doesn't start after installing nvidia driver with nvidia-inst

So I got EOS up and running, got the nvidia-inst script to install the drivers.

I ran nvidia-inst --drivers

515 is the latest supported for my card (RTX 3080Ti)

nvidia-inst --series 515 -t returned no errors so I ran it without test mode and rebooted, now xorg doesn’t start.

I tried installing linux-headers and I updated before and after, xorg still does not start.

(EE) lines in the xorg log say that it can’t open these modules: noveau, nv, fbdev, and vesa.

I checked /etc/default/grub and it has nvidia-drm.modeset=1 at the end of the GRUB_CMDLINE_LINUX_DEFAULT variable, so should xorg be looking for the nvidia-drm module instead of the ones that it looks for right now?

Is there a place where I need to add that module to a list to make it work?

You may need to add ibt=off as a kernel parameter in the deafult grub command line and update grub.

Thanks! It worked, but I’m wondering, what does that actually do? Should I remove it once the kernel gets an update?

See here about ibt=off: https://wiki.archlinux.org/title/NVIDIA#Installation


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.