Xmonad won't start after hard shut down

Hey everyone, a couple days ago I had to do a hard shut down (press and hold the power button) in order to rescue my computer after it ran out of RAM (and I assume swap as well) using Librewolf.

Ever since then, I’ve been unable to get Xmonad to start - using LightDM, I attempt to start the session, the screen goes black for a few seconds, and then it kicks me right back into LightDM. I’ve tried removing my xmonad.hs (by renaming it to xmonad.hs.old) as I’ve seen that help after updates, but it seems like that solution doesn’t work.

Does anyone perhaps have any idea of what else to try next? I’ve been unable to find anyone else running into the same problem I currently face.

Maybe: https://github.com/NixOS/nixpkgs/issues/25068
Or: https://www.reddit.com/r/xmonad/comments/6loqyp/need_help_xmonad_doesnt_seem_to_start_and_i/
Last one: ArcoLinux : 953 xmonad crashes after update - can not login with lightdm - YouTube

This does not solve your problem, but it will prevent a similar issue in the future:

1 Like

It actually seems to have fixed itself after an update to Xmonad and its Haskell libraries. I’m really not sure how that happened, but hey, it works now, thank you for your suggestions.

If I had to guess, maybe something happened to the packages themselves in the hard shutdown, so maybe uninstalling and re-installing would do the trick in this situation? I’d try it myself, but I’d rather not try to reproduce the issue without full confidence that it would work, but I’ll definitely keep it in mind if it happens again.

1 Like

Sorry for the double post, but I’m not sure how quote multiple people in one post on the forum quite yet (it’s been a very long time since I last visited an honest to goodness forum), but thank you very much for the solution, I’ll enable that key asap! :grin: