Xfce4-terminal won't stay scrolled back

xfce4 terminal keeps jumping to bottom of output when I scroll back to something I want to read. I have the unlimited scrollback checkbox ticked and my scrollbar is diasbled. Is there a way to stop this? If not, can someone recommend a different terminal emulator with lots of features that works in xfce? Thanks.

Welcome to the EndeavourOS forum!

Hard to tell the reason for the issue.

But you have plenty of alternative terminals available. Some of my personal favorites are:

  • terminator (lots of features)
  • qterminal (fast compared to many)
  • most if not all default terminals from other DEs, e.g. konsole (integrates nicely with dolphin file manager)

and then more.

  1. This sounds very odd. Never heard of this type of problem that doesn’t also affect other scrolling windows such as browsers.

  2. Xfce is very modular. You can basically install any terminal and just pick it as default in the Default Application chooser in Settings.

You have this only in terminal? Not in a browser?

Yes, it’s only in xfce4-terminal, drop-down or regular window. No problem scrollling back in browser, documents, etc.

I’ve also got xfce running in ArcoLinux and Linux Mint on a different machine and my xfce-terminal problem doesn’t happen in those distros; it’s EndeavourOS specific.

Thanks for suggestions about other terminal emulators; I’ve installed gnome terminal and guake and they’re working fine. I’ve always liked guake. Gnome terminal may be heavy but it’s like comfortable old blue jeans for me.

Thanks again everyone.

Welcome @ynot. If you are interested in solving this problem instead of choosing another terminal then we need more information to help you. I do not use Xfce BTW so these are just general questions.

Did you only change number of lines to scroll back in preferences? Or did you make other changes?

Have you rebooted or logged out and back in?

Did the scrollbar disappear when you chose unlimited scroll back? Or did you disable it?
Can you choose a large number for scroll back like 5,000, 10,000, 20,000, etc. instead of unlimited? Does the problem go away?

I think this is the config file for Xfce4 terminal. Someone who uses Xfce correct me if I’m wrong.
Delete or rename ~/.config/xfce4/terminal/terminalrc
Logout and login. terminalrc should be rebuilt/copied as default.
Run Xfce4 terminal, but do not choose unlimited scroll back. Does everything work as expected?

Same issue. I’ll scroll up a couple of thousand lines in the output, but it’ll jump back to the end after a minute. Very frustrating.

maybe enable and disable again “Scroll on output”? I am using XFCE and XFCE4-terminal and don’t experience this issue.
Can you give the output of

xfce4-terminal -V

Does it happen every time, after a minute, even if you’ve not pressed any key on the keyboard?

Pressing nearly any key would cause the terminal to return to the input line. I’ve been frustrated while scrolling the terminal with the mouse wheel, scrollbar or touchpad to find the terminal suddenly return to the input line after I press one of the direction keys (Up Arrow, Down Arrow, Page Up, Page Down), thinking intuitively that these keys would continue to scroll through terminal output. Actually, by design, these keys scroll through input history, not terminal output, so it makes sense that they would return you to the input line.

Correct. It usually happens when I scroll quite a bit up (usually via shift+PGUP) and try to get an exact selection to copy to the clipboard, but it’ll happening without touching the mouse (or keyboard) at all. Usually within seconds (maybe ten after I stopped scrolling). I disabled “Scroll on Keystroke” and it still didn’t make a difference.

How frustrating for you!

Unfortunately, the original poster in this thread, with the same or similar problem, didn’t offer (or hadn’t found) a solution.

I tried unsuccessfully to replicate the problem myself as follows:

I set the scrollback limit to 20,000, as you show in your screenshot.

I ran this script in the terminal, which generates 20,000 lines of output:

for (( i=1; i<=20000; i++ ))
do
   printf "$i\n"
done

I pressed Ctrl+Shift+PgUp repeatedly to move near the top of the output (line 292 of 20,000).

I made a cup of coffee and did some other stuff. When I returned about an hour later, the terminal was still showing line 292.

If you use another terminal, do you experience the same problem?