XFCE theming gnome apps issue

I am experiencing an annoying issue with XFCE that I don’t know were to start debugging.
I am using gnome-calculator but it has a dark themed results display window. So that i can barely make out the results (see below pic bottom right).
All my themes are light themes and no other app (as far as I can tell) seems to be affected.


I’ve even logged in to gnome and checked the settings there, but everything is light-themed there too.

This has worked up til recently when i have removed all gnome apps accidentally, then reinstalled just a few of them back, including gnome-calculator.

Any idea where this app could be taking its appearance from?

The GTK folks are f-ing things up at the moment when it comes to enforced themeing (and other issues), and they’re changing things constantly, so even if you find a solution today it might not work tomorrow. I just had a discussion about this with a disgruntled Arch-using firend, and she was NOT happy.

Sorry, no solution other than avoiding GTK.

You can look in .config/gtk-3.0 and see if there is a settings file that is affecting gnome-calculator.

Alternatively, you can try galculator – a calculator app that, IMHO, is better than gnome-calculator.

I would set gtk theme to adwaita to see if it results the same

2 Likes

Sorry for the necroposting, but I was wondering if you had found any effective workaround for this, @nate and @Mr_Ecks .

:rofl: :rofl: :rofl:

No solution but a good joke.

2 Likes

hi ed0.
I reinstalled everything (i.e. OS reinstall from scratch) and it was fixed (meaning the problem was not present in the new install).
The easiest solution would be to download a fresh copy of the theme in your ~/.themes folder. If that doesn’t fix it you’d need to do some debugging.

If i were to debug the same thing again, I’d look into the theme files itself and find something specific to the application, as I’ve realized a lot of themes add specific styling rules for various popular apps (look for css files in the gtk3 folder of the theme). Also If I weren’t able to find where the rule is defined, I would define my own rule to override anything that affects the screen element I was interested in.

1 Like

Could I ask you to please share some dotfiles for the relevant configurations, so I can compare and contrast, as well as draw inspiration? (first time I am dealing with this specific field). Thank you in advance!

~/.config/gtk-2.0
~/.gtkrc-2.0
~/.config/gtk-3.0
~/.config/xfce4
~/.config/dconf
1 Like

I have found an even better solution (for me, at least), which is disabling CSD (Client Side Decorations) altogether by simply installing:

https://aur.archlinux.org/packages/gtk3-nocsd-git/

Additionally, open xfce4-settings-editor and in xsettings set Gtk>DIalogUseHeader as false (untick box), to make sure the file picker is brought back to its former glory.

I expanded on this topic in this tutorial I have made → Tutorial: Restituting consistent window theming on XFCE - aka revert new window borders (CSD) to previous mode (SSD)

2 Likes