XFCE themes initialization

Hello! I installed EndeavourOS this weekend (Artemis Neo), then installed XFCE via pacman and configured it to my taste. After that I noticed that the EOS Welcome app has a button to apply Endeavour theme to XFCE. I tried it and got an instruction how to revert the change in case if I don’t like it: the dialog suggested to remove $HOME/.config/xfce4 and replace it with the settings backed up by the util. When I re-logined, I saw that all the configuration was lost, including the panels layout, widgets and so on, also the style I didn’t like, so I followed the instructions to revert the configuration. However, after replacing the config directory with the old one and restarting the session, most of my config wasn’t restored - all the screen looked the same except for the styles (and even the styles restored inconsistently). Seems that the recommended backup method doesn’t achieve it’s goal.

1 Like

Did you try to restore your settings while not being logged in in the graphical session?

The best way to restore your settings would be:

  1. Log out of your graphical desktop session
  2. Change to a text console (tty2) with CTRL + ALT + F2
  3. Log in on that console
  4. Backup and copy your .config/xfce4 directories using mv and cp
  5. Switch back to your graphical desktop (tty7) using CTRL + ALT + F7
  6. Log in and check your settings

You can switch back to tt2 and logout there if everything worked.

must be untagged …
But it could be caused by latest update for xfce4 to 18 ?
I will check…
Also, you need to make sure to reboot before you want to save configs as backup… they are not fully populated in the files before that.

just checked and I can restore my personal setup without any issue:


1 Like

This came into my mind as well: maybe this procedure should be done when XFCE is not running. I will recheck both scenarios.

Ok, I have found the cause, but I don’t understand how it’s possible. If I logout from XFCE, restore the config (from TTY or KDE) and login back - the restored config is corrupted. If I reboot instead of logging out - it works. Can somebody explain me, why? I use SDDM display manager which was installed together with the KDE bundle during EndevourOS installation. What is the difference between logging out and rebooting here? I thought DE is equally shut down in both cases.

P.S. If the reboot is really required before restoring a backup, please, include this information into instructions shown in your dialog box.