XFCE qbittorrent not launching after libtorrent-rasterbar update

qbittorrent not launching after libtorrent-rasterbar-1:1.2.10-1 update in XFCE

[marcelo@linux ~]$ qbittorrent %U
qbittorrent: symbol lookup error: qbittorrent: undefined symbol: _ZN10libtorrent5entryC1ESt3mapINSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEES0_NS_3aux12strview_lessESaISt4pairIKS7_S0_EEE

Odd - I guess that I’ll be working with a downgrade to libtorrent-rasterbar for the moment… At least that’s easy to do!


What is the downgrade version?

Edit: Mines not launching either.

[2020-09-23T07:35:39-0300] [ALPM] upgraded libtorrent-rasterbar (1:1.2.8-1 -> 1:1.2.10-1)

1 Like

I don’t have it on my system to downgrade. :weary:

[marcelo@linux ~]$ yay -Ss libtorrent | grep “libtorrent-rasterbar 1:1.2.10”
extra/libtorrent-rasterbar 1:1.2.10-2 (2.3 MiB 9.6 MiB)

New version available, maybe it’s not necessary to downgrade it anymore.
I’ll test

Just tested, it’s launching with this new libtorrent1:1.2.10-2

Also had to add QT_AUTO_SCREEN_SCALE_FACTOR=0 to my /etc/environment

I also took it off the ignore list, and updated a minute ago. It appears to have fixed that issue - but it still complains about authentication:

Error codes

Qt: Session management error: Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed
qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 9109, resource id: 13026020, major code: 40 (TranslateCoords), minor code: 0

This, however, does not prevent it starting up, and continuing to seed the new EnOS ISO…

strange, I’m not getting errors

Ya it’s working now with the update. I tried to downgrade and did something i didn’t like so i booted into a previous snapshot and updated. As i say it’s working now!

1 Like

It is possible that the fact that I don’t have your recommendation of
QT_AUTO_SCREEN_SCALE_FACTOR=0 in place matters. I have avoided that particular statement because of posts that suggest that any setting of it might go amiss. I use QT_SCALE_FACTOR=1.25 ( or 1.5, depending on which setup) - and it is suggested that they don’t play well together. Untested by me :grin: but I accepted it for now…

1 Like

I don’t know about that because mine wouldn’t launch either and i have nothing special.

Without that option, qbittorrent opens but I get some font problems, can’t read everything, menus get strange too…

Sorry if I’m posting something obvious, but on EOS you could simply run

downgrade libtorrent-rasterbar

and then choose the appropriate version for it to be fetched remotely and then get installed.

Btw, you can also “downgrade” to a higher version :slight_smile:

If downgrade isn’t available you can install it with
yay -S downgrade


Ya I tried but it didn’t seem available. So I tried something else and didn’t like the result so I booted into a snap shot before the last one and upgraded to the newer version that just came out.


Works fine here.