XFCE not saving samba passwords?

I just installed the latest endeavoros with offline xfce and am having trouble with it keeping passwords.

I have some samba shares that I want to connect to and it works great. I do the normal smb://ipaddresstoserver then put in the username and password and have it save it forever option in thunar.

I can browse and do what I need to. Then after I restart the computer I have to enter all the info in again because it wont’ save the username and password even though I selected save forever.

Any ideas?

Needs gnome-keyring.

yay -S gnome-keyring

Then log-in again and it should save.

Edit: you may need to open “Session and Startup” and tick the box for “Launch GNOME services on startup” under the advanced tab and reboot.

1 Like