Xfce -> Gnome: screen lock doesn't work

I’m sure there’s a guide out there somewhere on how to install additional Desktop Environments.

So, I followed that link. And now I am unable to lock my screen with super+L. If I run journalctl --follow and try super+L, I get the following:

Couldn't lock screen: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.Shell.ScreenShield was not provided by any .service files

I’ve tried looking for packages that might contain this. I’ve tried looking for Gnome extensions that might contain this. Both have come up empty. So I believe that this might not be an incredibly trivial problem. Which is why I am asking you for help instead of continuing my online search for answers to this riddle. Hopefully this question and it’s answer (:crossed_fingers:) can assist others on their journey as well.


Are you using lightDM or GDM?
GDM has screen locking built in, where LightDM doesn’t.
If you are using lightDM try to install gnome-screensaver.

1 Like

If you’re on xfce, gnome screen lock, as well as gnome extensions will not work. Those are for gnome only.

For xfce you will use xflock or xflock4 (I forgot what’s it’s called off the top of my head).

If you installed xfce and then gnome later, most gnome things don’t work if you haven’t started the gdm service instead of lightdm.

yay says gdm is installed:

extra/libgdm 42.0-1 (76.6 KiB 644.4 KiB) (Installed)
    Display manager and login screen - support library
extra/gdm 42.0-1 (719.6 KiB 4.4 MiB) [gnome] (Installed)
    Display manager and login screen

How can I be sure that I’m using it?

I am going from Xfce to Gnome. I had a working Xfce installation and I installed Gnome but there was no default installation of a screensaver or screen locker it seems.


systemctl status gdm

If it is not enabled, enable it

sudo systemctl enable --force --now gdm

which will replace lightdm (as display manager)

Note: This may log you out of your session immediatelly, so close any running apps (or do it from TTY)

There was actually a “Change Display Manager” button on the Welcome application. I clicked that, selected GDM, and it had me reboot. I rebooted, got to the gdm login screen, selected myself, then selected a Gnome session in the bottom right gear menu, and it’s all working now. Thanks for the help everyone!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.