XFCE Desktop Freezes When Installing Extensions on Chromium-based Browsers

Introduction: I’ve run into a rare issue that might be of interest to others. My XFCE desktop environment freezes when attempting to install any extension on Chromium-based browsers like Brave or Chrome. I’m sharing the problem, alongside a workaround and detailed steps I’ve taken towards troubleshooting, in hopes it might assist someone facing a similar situation.

Issue Description: The desktop environment freezes completely whenever I try to add an extension to a Chromium-based browser on my XFCE setup. The only immediate remedy I’ve found is to switch to another TTY (using Ctrl+Alt+F2) and manually restart the desktop manager with sudo systemctl restart desktop-manager.

Prerequisites for Reproducing the Issue:

  • XFCE Desktop Environment
  • Chromium-based browser (Brave, Chrome, etc.)
  • Intel graphics hardware
  • Running EndeavourOS

Workaround Identified: I discovered a workaround that allows for the installation of browser extensions without freezing the desktop:

  1. Within the browser’s settings, turn off the “Use system title bar and borders” option.
  2. Proceed to install the desired extension.
  3. After installation, re-enable the “Use system title bar and borders” setting.

This method successfully prevents the desktop environment from freezing during the extension installation process.

Debugging Steps (Unfinished):

  • System and Package Updates:
    • [x] Ensure your system and all packages, including Flatpak applications, are fully updated. Even after updating, the issue remains.
  • Testing with Native Chromium Installation:
    • [x] To isolate the issue, I tested it with Chromium installed directly from the EndeavourOS repository (sudo pacman -S chromium). The issue persists in the native installation as well.
  • Trying with a Different User Account:
    • [ ] Sometimes, user-specific configurations can be the culprit. Creating a new user account (sudo useradd -m testuser) and switching to it (su - testuser) to test Chromium might reveal if the issue is user-specific.
  • System Log Review:
    • [ ] Checking system logs for errors related to the graphics driver or Xorg can provide clues. journalctl -b lets you review logs from the current boot, focusing on any relevant errors.
  • Core Dump Analysis:
    • [ ] Enabling core dumps (ulimit -c unlimited) and analyzing them with coredumpctl after a freeze might help identify the cause.
  • Verbose XFCE Session Logging:
    • [ ] Adding XFSM_VERBOSE=true to your /etc/environment will enable more detailed logging. After a reboot, try to reproduce the issue and consult the verbose log ~/.xfce4-session.verbose-log.
  • Forcing DRI 2 for Intel Graphics:
    • [ ] If you’re experiencing this issue on an Intel graphics system, modifying the driver settings might help. Creating a file /etc/X11/xorg.conf.d/20-intel.conf with specific configurations to force DRI 2 could potentially resolve the freezing. See here: https://wiki.archlinux.org/index.php/Intel_Graphics#DRI3_issues.

Conclusion: While I haven’t fully debugged this issue to a conclusive resolution, I hope my findings and the temporary workaround provided can be of help to anyone experiencing similar problems. Sharing these steps and observations may save someone else the time and frustration of dealing with a freezing desktop environment.

1 Like