Xfce: Any Global Menus That Work?

Hi. This is just a tweak I’d like to make, but there used to be TopMenu-GTK and Vala-Panel for Xfce that could be used as a Global Menu like Unity had.

Is there anything out there for Xfce that anyone has used/tried/works?



Removed ::: thought i could answer … Sorry

edit ;;; post

Are you already using the Whisker menu, or the vanilla menu that came from the online install?

And with commands

yay -Ss xfce menu 
# or
yay -Ss xfce menu plugin

you may find other menus from the AUR.

i tested this. Seems to work.

installed vala-panel-appmenu-common-git (0.7.6.r7.g46c2fbb-1)
installed vala-panel-appmenu-valapanel-git (0.7.6.r7.g46c2fbb-1)
installed vala-panel-appmenu-xfce-git (0.7.6.r7.g46c2fbb-1)
installed vala-panel-appmenu-registrar-git (0.7.6.r7.g46c2fbb-1)

logout/in and i got the appmenu in the panel.

edit ::: you can find appmenu between the rest of xfce4 goodies.

edit ::: i think this will not work for all application. Like librewolf doesnt get the menu.
Or more deps need to be installed of vala.

edit ::: Libreoffice works

edit ::: install firefox-ubuntu-bin to get menu with firefox. It removes the previous firefox. Menu works.
source firefox buntu

Its becoming a bit of a messy post.

This is what I installed so far.


Working ::: so far tested

Firefox ubuntu

Its quit nice, i think i keep it for a while :slight_smile:

edit ;;; add scrot Desktop menu


1 Like

If you want it to be Unity - why not run that? Easy enough to get Compiz going, and Unity is a plugin for Compiz (last I tried it). Jes’ wondering…

1 Like

This is interesting! Thanks. I’ll try this later tonight. This is pretty cool!

1 Like

This is something I didn’t know you could do. If the previous suggestion doesn’t work, I’ll try this. Thanks!

1 Like

You’re right…this almost works! LOL It does work, but I guess some of the programs I use (Evolution, Gimp, Audacity, and more) don’t work, but it does work with a lot! Thank you! I’ll try this for a while and see if it’ll be good or frustrating. :smile:


Allmost indeed …

Gimp (2.10.24) works for me though.
Audacity doesn’t work for me either. Yet :slight_smile:

edit ::: Maybe i installed a bit more i can’t remember (like gimp working).

1 Like

If you are not attached to Xfce4 then switching to Unity is a choice.

A small disadvantage of having multiple DE’s installed, is that there will be a mix of e.g. system apps. Can be a bit messy.
A clean new system installation with the preferred DE works best in my experience.


Please forgive this question, but how would I be able to install Unity in EndeavourOS? I didn’t think that was possible.

In theory. it should run off an install of Compiz (it was originally a plugin for it) - but I haven’t set the whole thing up as yet to be sure about it. I have Compiz on a couple of installs. but I have so much vertical screen real estate that I haven’t tried Global menus (ie: Unity) as it is less alluring(!) to have them when there’s a long way to go to get to them! I know that because there an Ubuntu Unity remix that I popped on here for a while, and work didn’t flow like it used to…

Can’t commit to it, but I might try to see if it will go OK after a bit.

That’s pretty interesting. I honestly had no idea about that. Might be something I’ll look into. It’s not a deal breaker at all, but I did like Unity (yeah…one of those guys! LOL) and really don’t care for Gnome. Xfce’s about as close as I’m going to get, and that’s fine. It’s a very solid DE. I do appreciate the input from everyone, though! This was really cool to experiment with.