Xcursor size not even

Someone have this also?
cursor get bigger when I am into Firefox address bar or inside a Terminal?
bigxcursor
.
smallxcursor

I can resolve it by using:

xfconf-query --channel xsettings --property /Gtk/CursorThemeSize --set 11

from Terminal on XFCE4 but in settings I can set the size only 16 or bigger minus sign is greyed out:

It is the same for other cursor themes, and also happen on i3 and GNOME.

Sorry - can’t see how to help. I run with cursor size=72 (or 64 on some) - so my experiences don’t align well!

This is an annoyance, there are so many places to set the cursor:

cat .gtkrc-2.0
gtk-enable-animations=1
gtk-primary-button-warps-slider=0
# DO NOT EDIT! This file will be overwritten by LXAppearance.
# Any customization should be done in ~/.gtkrc-2.0.mine instead.

gtk-theme-name="Flat-Remix-GTK-Blue-Dark-Solid"
gtk-icon-theme-name="Hey-blue-dark"
gtk-font-name="Noto Sans,  13"
gtk-cursor-theme-name="Bibata-Modern-Amber"
gtk-cursor-theme-size=48
gtk-toolbar-style=3
gtk-toolbar-icon-size=GTK_ICON_SIZE_LARGE_TOOLBAR
gtk-button-images=1
gtk-menu-images=1
gtk-enable-event-sounds=1
gtk-enable-input-feedback-sounds=1
gtk-xft-antialias=1
gtk-xft-hinting=1
gtk-xft-hintstyle="hintfull"
gtk-xft-rgba="none"
cat ~/.config/gtk-3.0/settings.ini
[Settings]
gtk-application-prefer-dark-theme=true
gtk-button-images=true
gtk-cursor-theme-name=Bibata-Modern-Amber
gtk-cursor-theme-size=48
gtk-decoration-layout=icon:minimize,maximize,close
gtk-enable-animations=true
gtk-enable-event-sounds=1
gtk-enable-input-feedback-sounds=1
gtk-font-name=Noto Sans,  13
gtk-icon-theme-name=Hey-blue-dark
gtk-menu-images=true
gtk-modules=colorreload-gtk-module
gtk-primary-button-warps-slider=false
gtk-theme-name=Flat-Remix-GTK-Blue-Dark-Solid
gtk-toolbar-icon-size=GTK_ICON_SIZE_LARGE_TOOLBAR
gtk-toolbar-style=3
gtk-xft-antialias=1
gtk-xft-hinting=1
gtk-xft-hintstyle=hintfull
gtk-xft-rgba=none
cat .Xresources
Xcursor.size: 48

I think that is everywhere :smiley: