Xbox Elite series 2 controller not found by bluetooth

Hi there!
I just switched to EndeavourOS yesterday, and I can’t seem to pair my controller using bluetooth.
I’ve installed bluez, bluez-utils, and the xpadneo package, the controller works via USB, but I can’t seem to connect via bluetooth.

I’ve tried using the terminal to scan for it, I can see it there, but when i try to pair, then it says device unavailable:

Waiting to connect to bluetoothd...[bluetooth]# Agent registered
[bluetooth]# scan on
[bluetooth]# SetDiscoveryFilter success
[bluetooth]# hci0 type 7 discovering on
[bluetooth]# Discovery started
[bluetooth]# [CHG] Controller C8:94:02:16:94:8C Discovering: yes
[bluetooth]# scan off
[bluetooth]# hci0 type 7 discovering off
[bluetooth]# Discovery stopped
[bluetooth]# [CHG] Controller C8:94:02:16:94:8C Discovering: no
[bluetooth]# pair C8:94:02:16:94:8C
Device C8:94:02:16:94:8C not available

The bluetooth service seems to be running fine:

[yom@yomputer ~]$ systemctl status bluetooth.service 
● bluetooth.service - Bluetooth service
     Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; preset: disabled)
     Active: active (running) since Thu 2024-07-04 21:06:36 CEST; 21min ago
 Invocation: b6517c7898754457bd5302ab8bd124a6
       Docs: man:bluetoothd(8)
   Main PID: 7367 (bluetoothd)
     Status: "Running"
      Tasks: 1 (limit: 38375)
     Memory: 1.1M (peak: 1.7M)
        CPU: 47ms
     CGroup: /system.slice/bluetooth.service
             └─7367 /usr/lib/bluetooth/bluetoothd

The firmware on the controller was updated just a couple days ago while I was still on Windows.
I can pair and connect to other bt devices, and I just tried connecting the controller to a laptop running Linux Mint, which worked right away.
One post I found suggested using the LTS kernel, which didn’t help.
The system is up to date.
There’s several posts on the forum with similar issue, but none of them have a solution.

Does anyone have an idea that could help me figure out whats wrong? Let me know if there’s anything I could add that could help solve this.
Thank you.

Edit: here’s the system information, figured it might be helpful:

Operating System: EndeavourOS 
KDE Plasma Version: 6.1.1
KDE Frameworks Version: 6.3.0
Qt Version: 6.7.2
Kernel Version: 6.6.36-1-lts (64-bit)
Graphics Platform: Wayland
Processors: 16 × AMD Ryzen 7 5800X3D 8-Core Processor
Memory: 31,3 GiB of RAM
Graphics Processor: AMD Radeon RX 6900 XT
Manufacturer: ASUS

I also have one.

Xpad package runs it fine wired.

Wireless I needed xpadneo. Admittedly that breaks A LOT. It’s very difficult keeping this controller working on Linux.

I gave up and bought an 8bitdo USB Bluetooth dongle that claimed to work with it on everything including raspberry pi. It always works and works great . Best $20 I spent on my computer.

1 Like

Ah, I think I saw your post about it in another thread, if I can’t find a solution I might give that a try, thanks :slight_smile:

1 Like

If you do find a better option, please let me know and I’ll give it a go too.

It drove me nuts for months.

1 Like

I’m reasonably sure at this point that the bluetooth protocol includes a coin flip somewhere along the line to decide whether or not it’s going to work at all every time it’s invoked.

1 Like

It would usually connect. But the elite buttons all wouldn’t work. Or they would fit a few and then it was just get stuck shooting or driving left or something. It was all over the place.

I updated my system today and now I can connect the controller to my pc without a problem. Even shows me the battery level.