X11 Default cursor appears until login screen / desktop loads

The default X11 “X” cursor appears before the login screen loads. After that, it’s fine until I log in, where it once more shows the “X” cursor until the desktop loads. Is there a way to fix this?

I’m using Gnome and X11, I can’t use Wayland due to my laptop having Intel / Nvidia hybrid graphics.

You’d have to edit the root account’s default theme. But it’s not really recommended as updates may revert the changes, nor does it actually affect your system in any kind of important way.

Example: You can log in as root, set the cursor theme to the one used in your user account, then log out.

The issue is that the theme used on your user account is sometimes unavailable to root — for instance, if you downloaded the theme rather than installed it — unless you install it under root. BUT, THIS IS NOT RECOMMENDED.

If it’s a downloaded theme, it’s less likely to cause issues because all you have to do is copy the files from your regular user while logged in as root, set the theme, then log out.

Lastly, you’ll probably have to use dconf-editor — the ultimate settings editor.


Notice how many times I said this? This is just an aesthetic thing, so again, it’s not actually important.

Star Wars Tatooine GIF by Jeremy Mansford