X Session inside Wayland?

I have found something new to tinker with, So I have install wayland and I was logged into it but then quickly realized it does not work the GreenWithEnvy, Nvidia GPU Overlocker/fan control program due to nvidia settings or whatever relies on xorg, So what I was thinking is, Why not just try to run a X session inside a terminal and run gwe in that.

So I ended up doing this

Xwayland -retro -noreset :12
Then in a different Terminal I tried DISPLAY=:12 Gwe

Sadly this just gives the usual error,
So I tried DISPLAY=:12 startx

well this defiantly started X but it took over everything anyway I then ran Gwe in it and the program worked, However I was hoping to run an X session inside the terminal window or something like that or have like a hidden X session and have Gwe running in this.

I am out of my depth here but here is a solved thread from Manjaro forum where a user is trying to solve a similar problem. Perhaps it may give give you some ideas:


env GDK_BACKEND=x11 /usr/bin/<APP_NAME>
#So in desktopfile:
Exec=env GDK_BACKEND=x11 /usr/bin/<APP_NAME>

In the exec line of the desktop file, not do it? Never used GWE, what is it?

It is a overclocking/Fan Control application for Nvidia Gpus, Sadly running
env GDK_BACKEND=x11 /usr/bin/gwe

in a terminal allows the program to be loaded however it must not be a true X session or something because NV-Control is missing:

env GDK_BACKEND=x11 /usr/bin/gwe

Won’t run for me, so I uninstalled it :frowning:

Just log in normally to a wayland session, then switch to tty1 (ctrl + shift + f1), switch the session to x11, and log in again. The wayland session is now on tty2 (ctrl + shift + f2), and the x11 session on tty3 (ctrl + shift + f3).

Beside that, you could probably also do things like gamescope openbox, and get an x11 session in that way.