X.Org display drivers

Hello All,
I just found out about this distro this week and installed it on my laptop. I really like its speed and resources requirements so I registered my account.

I do have a question about display driver. It appears that VLC video performance is not good (it uses a lot of CPU resource). On the same laptop VLC plays well and CPU consumption is much less. Via the ‘inxi -G’ command I see the the followings:

  1. On EndeavourOS:
    server: X.Org 1.20.8 driver: amdgpu, ati unloaded: fbdev,modesetting,vesa
  2. On Manjaro:
    server: X.Org 1.20.8 driver: amdgpu, ati unloaded: modesetting

Could it be that the reason of bad video playing performance on EndeavourOS because fbdev and vesa were unloaded? If so, is there any way to have these drivers loaded so that I can test video performance the same way as with Manjaro?

If this is not the reason of bad video performance what can I do to investigate further?

Thanks in advance for your time.

Welcome! :smile:

Could you show the output of the following terminal commands:

lspci -k | grep -PA3 '3D|VGA|Display'
pacman -Qs xf86-video

Thanks @manuel.
Here is the output:

[nn@l14w1 ~]$ lspci -k | grep -PA3 '3D|VGA|Display'
00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Stoney [Radeon R2/R3/R4/R5 Graphics] (rev ca)
	Subsystem: Lenovo Stoney [Radeon R2/R3/R4/R5 Graphics]
	Kernel driver in use: amdgpu
	Kernel modules: amdgpu
[nn@l14w1 ~]$ pacman -Qs xf86-video
local/xf86-video-amdgpu 19.1.0-1 (xorg-drivers)
    X.org amdgpu video driver
local/xf86-video-ati 1:19.1.0-1 (xorg-drivers)
    X.org ati video driver
local/xf86-video-fbdev 0.5.0-1 (xorg-drivers)
    X.org framebuffer video driver
local/xf86-video-vesa 2.4.0-2 (xorg-drivers xorg)
    X.org vesa video driver
[nn@l14w1 ~]$ ^C
[nn@l14w1 ~]$ 

Not likely. You probably just don’t have them installed on Manjaro so they aren’t listed as “unloaded” there. It looks like you are using the same drivers on both distros.

Is your vlc version the same in both distros? Is it only vlc, or do you see the same issues in other players such as smplayer?

In addition to what @dalto said, you could uninstall xf86-video-ati since it is not used, and reboot. Though don’t know if that helps, but worth a try anyway.

1 Like

Thanks @dalto and @manuel.

VLC on both systems shows the same version: 3.0.8-13. I also removed ati driver but same issue.

As for other players, I downloaded smplayer and it appears that the difference is not much with smplayer. And playing the same video clip on Manjaro with VLC and smplayer, VLC use much less CPU than smplayer. This leads me to think that perhaps for some reasons GPU is not fully utilized by VLC on EndeavourOS and some work are done by software. I checked VLC settings on both distros and both show ‘automatic’ for hardware acceleration. Weird!

I dig a bit further with smplayer: it has an option to turn hardware video decoding on/off so I tried both options on both distros:

On EndeavourOS turning the option ON does not make a difference on CPU usage, but on Manjaro I can see CPU usage drops a lot. So I think on EndeavourOS for some reasons the graphic driver does not use GPU for video decoding and rendering. By the way, both distros have the same amdgpu driver version: 19.1.0-1 but Manjaro has kernel 5.6.3 vs EndeavousOS has version 5.6.4. That leads to my new question: how to downgrade the kernel to 5.6.3?

sudo pacman -S downgrade
sudo downgrade linux linux-headers 

It will ask you if you want to add them to your ignorepkg list. I would strongly recommend answering “N”

1 Like

@dalto, thanks for your quick response!
I did downgrade the kernel but hardware decoding did not seem to work on kernel 5.6.3 either. So, it was not the kernel.

Oh well, more digging… :slight_smile:

PS: I observed that this issue happens on both AMD and Intel graphic chips (I have another laptop that uses an Intel processor), so it may not be a graphic driver problem.

Could you check which video output modul is selected in VLC?

Arch Wiki hardware video acceleration AMD


Thanks, that’s it. The hardware acceleration libraries were missing! After loading those libraries by following instructions from the Arch wiki page in your post I can see that VLC now can play video smoothly and consumes much less CPU resource.

Appreciate everyone’s assistance, you guys rock! :+1:

Don’t forget to upgrade your kernel again. :wink:

Thanks for the reminder, I did when I upgraded the system.

1 Like