Wrong namespace on document element in

After I update my system just now I got a message
Wrong namespace on document element in '/usr/share/mime/packages/org.godotengine.Godot.xml' (should be http://www.freedesktop.org/standards/shared-mime-info)

Here is the full log:

[2023-03-11T01:38:23+0000] [PACMAN] Running 'pacman -S -y -u --config /etc/pacman.conf --'
[2023-03-11T01:38:23+0000] [PACMAN] synchronizing package lists
[2023-03-11T01:38:24+0000] [PACMAN] starting full system upgrade
[2023-03-11T01:38:46+0000] [ALPM] running '60-mkinitcpio-remove.hook'...
[2023-03-11T01:38:46+0000] [ALPM] transaction started
[2023-03-11T01:38:46+0000] [ALPM] upgraded eos-bash-shared (23-5 -> 23-7)
[2023-03-11T01:38:46+0000] [ALPM] upgraded girara (0.3.7-1 -> 0.3.9-1)
[2023-03-11T01:38:47+0000] [ALPM] upgraded go (2:1.20.1-1 -> 2:1.20.2-1)
[2023-03-11T01:38:47+0000] [ALPM] installed libspeechd (0.11.4-1)
[2023-03-11T01:38:47+0000] [ALPM] upgraded libsquish (1.15-3 -> 1.15-7)
[2023-03-11T01:38:47+0000] [ALPM] upgraded godot (3.5.1-4 -> 4.0-2)
[2023-03-11T01:38:47+0000] [ALPM] upgraded libnm (1.42.2-1 -> 1.42.4-1)
[2023-03-11T01:38:48+0000] [ALPM] upgraded linux (6.2.2.arch1-1 -> 6.2.2.arch2-1)
[2023-03-11T01:38:49+0000] [ALPM] upgraded linux-headers (6.2.2.arch1-1 -> 6.2.2.arch2-1)
[2023-03-11T01:38:49+0000] [ALPM] upgraded networkmanager (1.42.2-1 -> 1.42.4-1)
[2023-03-11T01:38:49+0000] [ALPM] upgraded zathura (0.5.2-1 -> 0.5.2-2)
[2023-03-11T01:38:49+0000] [ALPM] transaction completed
[2023-03-11T01:38:50+0000] [ALPM] running '30-systemd-daemon-reload.hook'...
[2023-03-11T01:38:50+0000] [ALPM] running '30-systemd-udev-reload.hook'...
[2023-03-11T01:38:50+0000] [ALPM] running '30-systemd-update.hook'...
[2023-03-11T01:38:50+0000] [ALPM] running '30-update-mime-database.hook'...
[2023-03-11T01:38:50+0000] [ALPM-SCRIPTLET] Wrong namespace on document element in '/usr/share/mime/packages/org.godotengine.Godot.xml' (should be http://www.freedesktop.org/standards/shared-mime-info)
[2023-03-11T01:38:50+0000] [ALPM] running '60-depmod.hook'...
[2023-03-11T01:38:51+0000] [ALPM] running '90-mkinitcpio-install.hook'...
[2023-03-11T01:38:51+0000] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
[2023-03-11T01:38:51+0000] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
[2023-03-11T01:38:51+0000] [ALPM-SCRIPTLET] ==> Starting build: 6.2.2-arch2-1
[2023-03-11T01:38:51+0000] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2023-03-11T01:38:51+0000] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2023-03-11T01:38:51+0000] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2023-03-11T01:38:51+0000] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2023-03-11T01:38:51+0000] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2023-03-11T01:38:52+0000] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: xhci_pci
[2023-03-11T01:38:52+0000] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2023-03-11T01:38:52+0000] [ALPM-SCRIPTLET]   -> Running build hook: [keymap]
[2023-03-11T01:38:52+0000] [ALPM-SCRIPTLET]   -> Running build hook: [consolefont]
[2023-03-11T01:38:52+0000] [ALPM-SCRIPTLET] ==> WARNING: consolefont: no font found in configuration
[2023-03-11T01:38:52+0000] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2023-03-11T01:38:52+0000] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2023-03-11T01:38:52+0000] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2023-03-11T01:38:52+0000] [ALPM-SCRIPTLET] ==> Creating zstd-compressed initcpio image: /boot/initramfs-linux.img
[2023-03-11T01:38:52+0000] [ALPM-SCRIPTLET] ==> Image generation successful
[2023-03-11T01:38:52+0000] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
[2023-03-11T01:38:52+0000] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
[2023-03-11T01:38:52+0000] [ALPM-SCRIPTLET] ==> Starting build: 6.2.2-arch2-1
[2023-03-11T01:38:52+0000] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2023-03-11T01:38:52+0000] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2023-03-11T01:38:53+0000] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2023-03-11T01:38:53+0000] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2023-03-11T01:38:53+0000] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: wd719x
[2023-03-11T01:38:53+0000] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: aic94xx
[2023-03-11T01:38:53+0000] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: qed
[2023-03-11T01:38:53+0000] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: bfa
[2023-03-11T01:38:53+0000] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: qla2xxx
[2023-03-11T01:38:53+0000] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: qla1280
[2023-03-11T01:38:53+0000] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: xhci_pci
[2023-03-11T01:38:54+0000] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2023-03-11T01:38:55+0000] [ALPM-SCRIPTLET]   -> Running build hook: [keymap]
[2023-03-11T01:38:55+0000] [ALPM-SCRIPTLET]   -> Running build hook: [consolefont]
[2023-03-11T01:38:55+0000] [ALPM-SCRIPTLET] ==> WARNING: consolefont: no font found in configuration
[2023-03-11T01:38:55+0000] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2023-03-11T01:38:55+0000] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2023-03-11T01:38:56+0000] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2023-03-11T01:38:56+0000] [ALPM-SCRIPTLET] ==> Creating zstd-compressed initcpio image: /boot/initramfs-linux-fallback.img
[2023-03-11T01:38:57+0000] [ALPM-SCRIPTLET] ==> Image generation successful
[2023-03-11T01:38:57+0000] [ALPM] running 'dbus-reload.hook'...
[2023-03-11T01:38:57+0000] [ALPM] running 'eos-reboot-required.hook'...
[2023-03-11T01:38:57+0000] [ALPM-SCRIPTLET] ==> INFO: Reboot is recommended due to the upgrade of core system package(s).
[2023-03-11T01:38:57+0000] [ALPM] running 'gtk-update-icon-cache.hook'...
[2023-03-11T01:38:57+0000] [ALPM] running 'rebuild-detector.hook'...
[2023-03-11T01:38:57+0000] [ALPM] running 'update-desktop-database.hook'...

System info:
EndeavourOS with kde wayland on AMD cpu+gpu laptop
Same message appears on my desktop, that is EndeavourOS with kde wayland on intel + nvidia laptop

Seems like an upstream or packaging issue if Iā€™m right.

So there is nothing I can do? Just need to wait for them to fix right?

Yep. Either upstream or the packager should fix this in an update.

You might want to report this to Arch Linux forum.

1 Like

Reported here for anyone who might want to track:

1 Like