Workspace/app unresponsive- Slack and mailspring (solved)

Good Day
I’m coming across a strange issues with 2 of my apps, Slack and Mailspring are unresponsive after a few mins. Both are AUR packages and after a few mins the app is wont respond to anything interaction. I also had the same issues with Slack Flatpac so I don’t think its an AUR issues

Slack- I can see new messages as they are sent but the app is just stuck for me to interact with it, almost like a view only role

  • I have slack on a 2nd monitor, it will go blank and reload (spinning icon) and reload on its own.
  • Making floating or changing the window doesn’t help

Mailsping- I keep on workspace 2 and when I switch to #2, whatever was the the previous screen still show on the workspace 2 and is unresponsive also. I have to use xkill to clear #2 and reload.

Found this last night

Changed fro dunst to xfde4 to see if that helps any
exec --no-startup-id /usr/lib/xfce4/notifyd/xfce4-notifyd &

my issues are solved, switching from dunst to xfce4 notification solved all my issues.


Desktop notifications

#exec --no-startup-id dbus-launch dunst --config ~/.config/dunst/dunstrc

alternative if you installed aside with XFCE4:

exec --no-startup-id /usr/lib/xfce4/notifyd/xfce4-notifyd &


Please mark your post with the solution as solution to help other users having the same issue. The option is available by clicking the three … Below your post.

1 Like

Thank you, I didn’t know that was an option. I copy and pasted the part from my .config/i3

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.