Woof OS Qtile Help

i am was so impressed by this Qtile spin, i decided to try it. i have 3 problems now.

  1. How to load wallpaper on startup through autoload.sh
  2. My plank does not autohide after i load them on autoload.sh like plank &
  3. Similarly my conky clock does not load even after the entry conky -s ~/.conky/conky.conf. However it works from command line if i run it after loading Qtile

Can someone experienced decipher what is going on.
2021-12-11_10-27

1 Like

Use your favorite wallpaper setter. For me it is feh

feh --bg-fill /path/to/wallpaper

It will probably hide when you have application open and maximized. If it doesn’t, you can change settings from plank.

Put the conky command at end of autostart.sh.
Otherwise, you can also put conky -s ~/.conky/conky.conf 2> ~/.conky_errors to log errors in ~/conky_errors.

PS. If this is happening after the stock installation, this may be a bug, and you could inform the developer(s) about it.

1 Like

Maybe you run a version of conky that I am unfamiliar with. With mine, you run it with conky -c path/filename - or maybe with conky -p 5 -c path/filename if you need a pause before running it (I use sleep in a script instead). What is this -s? I’ve never seen that…

1 Like