Wont load installer

New here and had run endeavour easily before, upgraded my desktop to newer hardware, but now I am unable to install this. I can although install it using virtual box, but not directly onto my SSD.

BIOS up to date
Secure boot keys are removed
Secure boot is disabled

Endeavour OS version - Cassini- 22-12

UEFI is enabled

Hardware
Motherboard - ROG Crosshair VIII hero (wifi)
RAM - 64 GB
GPU - AMD Radeon 6950XT
CPU - Ryzen 9 3900X

Photo of the error is after selecting any of the options presented on the initial USB boot media from the github

What did you use to put the ISO on the USB?

i used imageusb from passmark

running FAT32
also have tried NTFS to no success

If you are using Windows, try using Etcher.

That actually worked.

Why does etcher work but not imageusb?

I have no idea what imageusb is doing but writing a Linux ISO is different than writing a Windows ISO.

A Linux ISO has to be written directly as-is to the media. The partition table, the filesystem and the data are all contained in the ISO. So when you said, you tried both fat32 and ntfs that didn’t really make any sense in this context.

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.